1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

Want help about Kenwood mini HI-FI home Audio

Discussion in 'Gadgets / Electronics / Laptops' started by bhai, May 10, 2012.

  1. bhai

    bhai Esperto

    Messages:
    1,182
    Ahmednagar
    Grande Punto 1.3 90 HP
    Hi I own Kenwood Mini HI-FI home audio system XD-571S from 1999.

    In 1999 kenwood series was marketed by Videocon.

    It has a magnafiscant 3d surround output of 100 Watt RMS with 2 surround satelite speakers. I love the system same as my 90 HP.

    Today I opened it for cleaning. I blowered it with medium speed.

    But after that it refused to start. So I again opened & checked for any loose ribbon connectors. It has voltege selector switch of 110 & 220 v. Power supply was present upto its voltege selector switch.

    While trying, I accidently operated voltege selector switch to 110 v while power ON.
    That time small spark jumped out. After that power supply is not present in voltege selector switch. Now I have to visit ASS of Videocon. Since model has been discontinued spare problem may occur same like the great Fiat Uno.

    If due to bad luck spare is not avialable I have to throw this masterpiece in junkyard.

    I think it can be ON by removing selector switch. Bypass of switch.

    DIY proved costly. OR

    Can I have new HI-FI audio system of Kenwood? If yes where. But I want only kenwood.

    No Sony,Panasonic, Sharp & other brands.
    Last edited: May 10, 2012
  2. I think the damage might be more than just the voltage selector switch. I am not sure whether there will be any breaking logic (like fuse or something) when wrong voltage is supplied.

    You can try to repair it in local repair shops.
  3. Ganges

    Ganges Esperto

    Messages:
    3,121
    Driver Seat _/
    :
    Grande Punto 1.3
    if i think and go back to my engineering studies ,then definitely the transformer might have got damaged ?
  4. bhai

    bhai Esperto

    Messages:
    1,182
    Ahmednagar
    Grande Punto 1.3 90 HP
    There is protection mode utility if something happens wrong.

    There is no bad smell of transformer burning. & no burning smell from selector switch also.
    Only small spark occured from voltege selector switch. So let's finger cross.
  5. bhai

    bhai Esperto

    Messages:
    1,182
    Ahmednagar
    Grande Punto 1.3 90 HP
    Good news. Audio system started to blast output.

    Spark was due to 2 blown fuses. Fuses replaced. Still system was on sleep mode.

    Then I checked ribbon connector. One connector found loose. Removed & refitted.

    It started. Blown fuse kept entire precise circuit. All task done DIY.

    Mods you can close topic.

    ---------- Post added May 12, 2012 at 12:27 AM ---------- Previous post was May 11, 2012 at 11:01 PM ----------

    Thanks Sounder & Ganges for inviting my attention to fuse section.
    I forgot to express my feeling thanks in the joy.

    ---------- Post added at 12:28 AM ---------- Previous post was at 12:27 AM ----------

    Thanks Sounder & Ganges for inviting my attention to fuse section.
    I forgot to express my feeling thanks in the joy.

    ---------- Post added at 12:30 AM ---------- Previous post was at 12:28 AM ----------

    Thanks Sounder & Ganges for inviting my attention to fuse section.
    I forgot to express my feeling thanks in the joy.
    Last edited: May 11, 2012

Share This Page