1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

VENT(O)ed out because I needed a (T)JET

Discussion in 'Linea 1.4 T-Jet' started by tjetdriver, Nov 25, 2010.

  1. tjetdriver

    tjetdriver Amatore

    Messages:
    160
    Bengaluru, India
    past 2 days the t-jet is just getting admired guaranteed !!!
    the thing is i am waiting to take the t-jet out. but i dont want to take it in a bumper-bumper traffic.
    during christmas we are going to take it to pondicherry.

    I just read another thread that the ODO of their blinks. Mine is blinking from the day i have taken it.
    So i guess it should not be. I will have to take it to the service guy and then see.

    Maybe best idea is to meet another T-jet owner and do an apples-apples comparision ;)
  2. Rajen

    Rajen Regolare

    Messages:
    275
    Bangalore
    Madhukar

    Had checked yesterday evening and today morning about ODO issue. There is NO BLIKING of ODO either during the starting or during running.

    Suggest check with the Service advisor at ASS.
  3. PaddleShifter

    PaddleShifter Staff Member Janitor

    Messages:
    2,697
    Chandigarh
    Grande Punto 1.3
    @T-Jet driver: I advise you to disconnect the negative terminal of the battery for 10 minutes. Hopefully this will resolve the issue.
  4. tjetdriver

    tjetdriver Amatore

    Messages:
    160
    Bengaluru, India
    PaddleShifter - I will try today and see.
    If not tomorrow I will take it to the ASS. The problem the nearest ASS is far for me... @Peenya.
  5. adutt

    adutt Amatore

    Messages:
    191
    New Delhi
    Hey Team....not the ODO but i have experienced the headlights blinking or going low when the engine revs go really low....just before stalling. It did not even happen in my Palio. This i thought should have been a thing of the past when premier padminis use to do it.

    Is it normal ?? Has anyone experienced he same??
  6. tjetdriver

    tjetdriver Amatore

    Messages:
    160
    Bengaluru, India
    I tried and did not work.
    Will go sometime and get it checked.
  7. tjetdriver

    tjetdriver Amatore

    Messages:
    160
    Bengaluru, India
    No i have not seen this in mine.
    Btw i observed today thar there is no spanner in the tool box. Need to check that.
  8. tjetdriver

    tjetdriver Amatore

    Messages:
    160
    Bengaluru, India
    I took the T-Jet on a long drive. Had the chance to go to Tirupathi unexpectedly. So drove around 580 kms in 24 hours. Did not go beyond cross 100.. but most of the time was @ 80.The car handled beautifully in the ghats and bad roads. The rear seat passengers were very happy. The MID showed me that I got a mileage of 13(12.8 to be excat), which is good for the highway.

    In pin drop silence, there is a squeak sound on bad roads near the left front door and rear right door. So need to get it checked.

    This friday will be taking it to Pondycherry and will complete about 900-1000 kms and will leave for first service after coming back.
  9. Ravi

    Ravi Staff Member Janitor

    Messages:
    6,001
    Bangalore
    Grande Punto 1.3
    Great, can you put some suggestions here - viewtopic.php?f=25&t=1317
  10. VIVEK

    VIVEK

    Messages:
    2
    Mysore
    Heyy... ::D enjoy the trip dude..!!!
    Even i was in pondy 2 days back..!!
    waitin for ur travalouge...!!! post more pics...!!! :up

Share This Page