1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

TJet+ Turbo action missing between (1500 - 2000 RPM)

Discussion in 'Engine Compartment' started by kr_vasudev, Feb 13, 2014.

  1. kr_vasudev

    kr_vasudev Superiore

    Messages:
    611
    Bangalore
    All,

    I have given my TJet+ for 4th Servicing. I had few problems with the car before the service and all these were fixed. I was a happy customer period.

    After the servicing, the turbo punch was missing at 1750 RPM range, after one week of servicing I had to visit Tirupati, after crossing Hoskote I hit 120+ and it took like few seconds to hit 140+ and errr check engine light comes up.

    I return back to Bangalore and give the vehicle for checkup -- this is second visit. SA mentioned there is missing turbo pressure and ECU errors are cleared. I was happy at this point as check engine light was not seen. SA mentioned battery is weak. I did replace Exide with Amaron 55 Din yesterday.

    I wasn't happy the way TJet was driving, the turbo kick was not seen at all. Today went to service station again -- third visit.

    SA examined the hose pipes from Turbo that connects to AIR and other hose pipes + wires were all folder together. He did notice that one of the hose pipe was completely bulged. This was one reason why I missed the turbo kick and that check engine error.

    SA fixed all those pipes and wires, I did not want to come home without test drive, I hit Hebbal flyover and tested 160+ read check engine did not appear this time.

    Pending Issue: I still do not feel the turbo effect. Car is able to hit 160+ but at what time same as 1.4 NA !

    I experienced turbo effect for 32K KMS, SA says sir drive for 3 - 4 days, turbo effect you will feel :confused:

    My Concern: Since the hose pipes were bulged, I suspect something might have caused to fail the Turbo, however there is no error seen on on board controls.

    Thank you for reading with patience, by far this is my longest post in TFI

    Service Station: Ebony Motors
    Vehicle: TJet + 32K ODO
    Last edited: Feb 13, 2014
    1 person likes this.
  2. kr_vasudev

    kr_vasudev Superiore

    Messages:
    611
    Bangalore
    Delivery has failed to these recipients or groups:

    'service@fiapl.com' <mailto:service@fiapl.com>
    The recipient's mailbox is full and can't accept messages now. Please try resending this message later, or contact the recipient directly.
  3. Ravi

    Ravi Staff Member Janitor

    Messages:
    6,001
    Bangalore
    Grande Punto 1.3
    Email id for Fiat service has changed, check contact section. Or check Fiat website.


    Sent from my Nexus 4 using Tapatalk
  4. kr_vasudev

    kr_vasudev Superiore

    Messages:
    611
    Bangalore
    Thank you Ravi, Sure I will and e-mail them
  5. kr_vasudev

    kr_vasudev Superiore

    Messages:
    611
    Bangalore
    I sent an e-mail to Fiat. I have received response.

    They have spoken to SA and as I mentioned earlier I have to visit after 3 days, that will be my third visit after my service.
  6. Anup

    Anup Regolare

    Messages:
    303
    Bangalore
    Bangalore
    Grande Punto 1.3
    Hi Vasudev,

    Why don't you try switching your FASS to a KHT or Vecto and just go as a new complaint, a fresh pair of head might help find the culprit inside.
    Bulging of the hose pipe can happens due to excessive heating (do you have a practise of waiting for atleast minimum 60 seconds before/after a trip ? If not,that is a good practise to follow for a Turbo charged cars) or if another linking hose is giving too much pressure, please have them check the entire Turbo unit starting from the outside to all the internall hoses.

    For now all I can suggest is if you can a nice a garden hose pipe in a mild force and sprinkle water with little pressure over the Turbo fins (to your lower part of the grill) and see if any traces of dirt.

    After a nice wash try driving the car,normal practise for a Turbo car is to drive without/use minimum Turbo until the water temp has reached Half then charge the Bull and see if you find any difference.
    Last edited: Feb 14, 2014
    1 person likes this.
  7. kr_vasudev

    kr_vasudev Superiore

    Messages:
    611
    Bangalore
    Hi Anup,

    I follow the requirements of the turbo car. Morning I wait until the RPM falls below 900 in idling.

    Hose pipe bulging might be because it was folded and turbo pressure was blocked due to bend pipe.

    I am missing the turbo punch, 1750 i was changing gears, now it is like above 2000 RPM and also not happy with the engine tune. The sweet whistle melody of turbo is completely gone !

    Like minds think alike. Since there is a free checkup camp, I am going to visit KHT tomorrow.

    Thank you
    Vasu
    Last edited: Feb 14, 2014
  8. puchoo

    puchoo Regolare

    Messages:
    271
    Delhi / Shimla
    Were you able to get the problem diagnosed and solved. I am having similar issues , will put u a thread on it and wondering what the problem might be. Happened to me as well post the first service of the car , first time i took it back there was a loose pipe , now i know the turbo comes on but common symptoms - no kick at 1800 RPM , engine seems to be a bit sluggish in terms of RPM climbing etc etc

  9. Scorpioman

    Scorpioman Novizio

    Messages:
    26
    India
    Hi Guys, Have you noticed any increase in mileage with the turbo kicking in later? The reason I ask is because I heard when you give the car to the ASS and even hint at mileage being low, they tune the car for more mileage and in turn that effects the overall tuning including the turbo kicking in later.
  10. Navneet

    Navneet Amatore

    Messages:
    58
    Mumbai
    Mumbai
    Linea T-Jet
    Guys, any one here who has got this issue rectified. My TJet + is also facing same issue. The Turbo kick at 1500+ RPM is not at all there.. Very Little Pick Up. SA (Balaji Auto ) says its there, but I know my car and I know how it use to perform.. My 1.2 Palio is also having much better Pickup than her.. Guys please help in this issue as I am trying hard to get my car back in action..

    Balaji has told , that it might be an Fuel Pump issue. But how can that relate to Turbo? Also my TJet average is not that great. Its always around 11.6. It goes upto 160, but with very heavy lungs and occasional turbo pressure error i.e Check Engine Error for last 6 months... Any TJet here , has got this issue resolved.???

Share This Page