1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

TJet+ Acceleration Issue post 3rd Service

Discussion in 'Engine Compartment' started by speedJet, Jun 19, 2014.

  1. Ganges

    Ganges Esperto

    Messages:
    3,121
    Driver Seat _/
    :
    Grande Punto 1.3
    My left fog lamp blown away,i used to get the amber light and says check for number plates lights it was temporary.Once i restart again the amber light disappears and later no messages.Also i get Airbag failure message.
    i knew that my battery has gone old and its due to change.the service centre guy(TASS) asked me to check once the alternator output.

    As you have checked with battery,give a try on alternator output

  2. speedJet

    speedJet Superiore

    Messages:
    856
    Gurgaon
    Thanks Ganges. Alternator output has to be checked by FASS or we can do it?
  3. Ganges

    Ganges Esperto

    Messages:
    3,121
    Driver Seat _/
    :
    Grande Punto 1.3
    this should be done by FASS,if you have FASS in your region(we dont have)

    i too dont have any idea on it,but i have to check.

    May be tomorrow i will go to my local mechanic.
  4. speedJet

    speedJet Superiore

    Messages:
    856
    Gurgaon
    ok thanks, I will ask FASS to do it then
  5. Italia-Linea

    Italia-Linea Staff Member Janitor

    Messages:
    2,123
    Pune
    You can check alternator output yourself. Just start the car and measure the voltage at the battery terminals , it should be about 14.2 volts.

    If the idle is falling every now and then it must be either the coils or the idle control stepper motor.
    2 people like this.
  6. speedJet

    speedJet Superiore

    Messages:
    856
    Gurgaon
    Already checked in the morning - it was showing 14.2 volts when car was running. I will check at cold start also tomorrow morning

    The idle falls at cold start since past couple of days. Before that it was only acceleration issue. I guess this maybe due to coils. Hope that examiner shows something this time (EOBD light came up once a couple of days back - but cleared after that) otherwise FASS will be reluctant to do anything and will just send me back saying "all is well"
    Last edited: Jun 20, 2014
  7. speedJet

    speedJet Superiore

    Messages:
    856
    Gurgaon
    In past few days, no error has been seen on the dashboard or the MID. All lights come up regularly as they should. The idle drop issue has also kind of disappeared - however car feels jerky at times

    I had been to FASS on the weekend. They connected the examiner (using the non-red wire) of Engine and checked. No errors shown. The red wire for the examiner has conked off at FASS and hence other modules of the car cannot be checked right now as per FASS. I have been told that the wire should be there with them by next week and I should come again at that point of time. All my other requests for checking were kind of rejected by FASS mentioning "All is well"
    Last edited: Jun 23, 2014
  8. speedJet

    speedJet Superiore

    Messages:
    856
    Gurgaon
    Its been around 7 to 8 visits to FASS without much luck in the past 1 month. FASS does not have the red cable for examiner and was just giving lame excuses. Finally they took my car to another FASS and I had to pay for the examiner check-up costs

    The error that showed up was D0602 - CAN line error, intermittent. FASS gave me the explanation that since battery had discharged this is not an actual error. They cleared the error and gave the car back

    While the power has reduced, the fuel economy has also gone down after the 3rd service. Looks like escalation to Fiat is the only option left now
    Last edited: Jul 7, 2014
  9. speedJet

    speedJet Superiore

    Messages:
    856
    Gurgaon
    After about total 8 unsuccessful/non-fruitful visits to multiple FASS, I decided to go back to the basics and start afresh. The trouble had started after 3rd service and things were fine before that. So I decided to check each detail of the 3rd service which I had assumed to be fine. I checked the service receipt and found a mismatch on couple of oils - transmission oil and power steering oil. Ones listed in the receipt were a level below that subscribed by Fiat. I escalated to the service centre GM, spoke with him and he agreed to get it checked. On my visit to the service centre, I found that transmission oil at the service centre was the one prescribed by Fiat however the power steering oil was not as per specification (ATF DEXRON II was used). The service centre did not have the power steering oil of ATF DEXRON III specification. I was asked to come again. On my 10th visit, they changed the transmission oil (got it replaced because I was not sure what they had put in the 3rd service). On the 11th visit, the power steering oil of proper spec was replaced

    For now, i feel that power/acceleration issue may have got resolved but would wait for highway runs to confirm the behavior. Just for the benefit of others on this forum, I am listing down the symptons that appeared due to use of mineral oil by FASS:
    - power/acceleration poor at times especially during hot days (> 35 degrees)
    - engine appearing noisy at times as though it was loaded
    - drop in mileage by 2 kmpl in city and 3-4 kmpl on highway

    Also, when transmission oil is replaced, please make sure that the container from where the oil is sucked is clean. FASS generally uses the same container to store transmission oil when it is repairing some car. So essentially during service it is quite possible that the oil that gets into the transmission is actually new+old oil mixed

    It is very surprising that FASS does not know the correct specification of oil that has to be used. Also, it took me around 11 visits to get this resolved. All inputs were provided by me and FASS always maintained that things are fine. I hope that FASS was correct in one aspect though - the EBD error and CAN bus error were mostly due to some glitch with the battery as it has never again shown up

    Hopefully my issue would now be resolved - will keep everyone posted
    Last edited: Jul 29, 2014
  10. pabhishek

    pabhishek Esperto

    Messages:
    1,379
    Oslo
    Pune
    Linea T-Jet
    Good to hear speedjet that alls well!!::T

    And yes it will help lot of other tjet owners inlcuding me.

    Happy tjetting!

Share This Page