1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

Suspension noise eludes detection, please help

Discussion in 'Engine Compartment' started by theblack, Oct 15, 2013.

  1. theblack

    theblack Esperto

    Messages:
    2,188
    Bangalore
    A few days after my RJ trip i started noticing a strange kring kring noise from the right side of the car whenever i went over humps, ditches.
    I figured it might be because of dirt accumulation so had it washed and the noise seemed to die out. However it resurfaced just after a few kms of driving.

    That's when i took it to my mechanic to get a proper solution and we dismantled the whole suspension ,lubricated it and put it back.
    Again the noise went only to resurface after a few kms of driving.

    There was nothing visible in the entire suspension setup that begged our attention ,except for a slightly damaged right lower arm.
    Since i was not certain that its the lower arm issue and wanted to check it. I picked up a fellow TFIan's spare lower arm that was in good condition and fixed it.
    Even after the change i see that the noise still persists.

    Interesting bit : this noise does not come in the very initial kms of my drive. i.e . When i start to office in the morning ,for about 4-5 kms i dont hear this noise (by then i would have gone over number of potholes and humps) after that i start hearing this noise and it does not die down at all.
    Again in the evening (after the car has had a good time resting ) i dont hear this noise which comes back later.
    What i've observed from this is that when the car is idle for a long time (>5-6hrs) this noise does not start immediately .

    After extensive discussion with my mechanic he is positive that
    1.) the problem is not with drive shaft
    2.) the problem is not with steering column
    3.) the problem is not with engine mounts.

    I have recently (about 8-10k kms earlier) replaced the strut pads also.
    So now i've run out of ideas to look for issues. Please help me out with this .

    To Re-iterate.
    1.) noise is only appearing after driving for a few kms and stays that way
    2.) Overnight halt of the car somehow seems to mask this noise at first crank/drive
    3.) i've already changed the lower arm and yet the noise persists.
    4.) the noise is coming from right to right-center of the car . Sometimes i feel that in my steering wheel as well.

    Note : I'm running on super hard tyres.
  2. pdydeva

    pdydeva Regolare

    Messages:
    442
    India
    Check out this video if you haven't before. May be something'll click. In fact we ourselves can diagnose and find out the root cause based on this guy's suggestion.

    Last edited: Oct 15, 2013
  3. theblack

    theblack Esperto

    Messages:
    2,188
    Bangalore
    All things spoken here were looked at and none are suspected :(
  4. pdydeva

    pdydeva Regolare

    Messages:
    442
    India
    How about replacing the strut itself to see if the noise goes away. May be the strut has gone bad internally (just a wild guess, still may help in ruling out a possibility).
  5. theblack

    theblack Esperto

    Messages:
    2,188
    Bangalore
    Yes that's probably one thing that i'm yet to try but i need a spare strut to try out. secondly i highly doubt its a strut issue so keeping it as the last resort!
    Any other suggestions guys
  6. Ganges

    Ganges Esperto

    Messages:
    3,123
    Driver Seat _/
    :
    Grande Punto 1.3
    I doubt on strut pads though it is recently changed.
    When i had a similar problem; first time been to FASS they changed the shockabs for RH few days no sound.then later again came up,this sound gone more as days passed then changed RH lower arm with strut pads.sound completely gone.
    Give a try on strut pads.Thanks to TASS.
    Last edited: Oct 16, 2013
  7. animeshkumar15

    animeshkumar15 Timido

    Messages:
    9
    BLR
    I too had faced a similar situation on my Punto, it was discovered that Mounting Pads where the culprit.
    Jack Your car then move the steering towards left or right, keep a hand on the shock absorber rmounting area. If you get the sounds, Voila !!
  8. theblack

    theblack Esperto

    Messages:
    2,188
    Bangalore
    Since i'm not facing any abnormalities while driving or in car dynamics i want to do an end to end research on this one.
    This issue has gone from a simple swap to fix to a PITA. So i'm not willing to invest money on parts unless i know for sure that its the culprit.
    Secondly, when the suspension was first opened the pads were checked by my mechanic and he gave a clean chit for that as well. :(
  9. What about Link rod?
  10. theblack

    theblack Esperto

    Messages:
    2,188
    Bangalore
    Link rod was also tested to be fine

    Sent from my Q1000 using Tapatalk 2

Share This Page