1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

Sudden loss of power while overtaking

Discussion in 'Engine Compartment' started by Rituraj, Jan 14, 2013.

  1. Ganges

    Ganges Esperto

    Messages:
    3,122
    Driver Seat _/
    :
    Grande Punto 1.3
    Thats too old man, we saw Dhoom 3 too now and Amir Khan as PK :D

    Try to give a shot with new battery of high amps.Amaron FLO 55amps.
    Rituraj likes this.
  2. PKMohan

    PKMohan Amatore

    Messages:
    59
    Bangalore
    Dear all,
    My Linea also joined in this league from last month. My car is about 45 months old and completed 49k kms so far and still running on stock battery. Based on this thread I will get the battery checked and changed at the earliest. But so far all three instances of powerloss happened on highways and that too when I suddenly decelerate due to traffic or speed breaker. In all these instances I drove more than 100-150kms before experiencing this powerloss due to deceleration. Such long drive should have charged battery fully.

    Is there any relation between sudden deceleration and powerloss?

    I drove straight to nearest FASS after the first powerloss and Engine scanner didn't show any issues.

    I haven't experienced this so far within the city drives and of course we rarely get chance to go to high speed and suddenly decelerate, and didn't want to try that in city traffic.

    Regards
    P K Mohan
  3. Deepak

    Deepak Regolare

    Messages:
    456
    KA-30
    Bengaluru
    Punto Evo 1.3 90 HP
    @PKMohan : Did the issue in your got resolved?
  4. varin11

    varin11 Superiore

    Messages:
    821
    Mumbai
    Bombay
    Linea 1.3
    I have faced power loss only once in my 2009 Linea done 86000 Kms that too on the highway at a speed over 110 kmph.The CS told me this could be some wrong signal by sensor or bad fuel.
    Have been careful about where to fill the fuel from and the issue never resurfaced even at high speed.
  5. Rituraj

    Rituraj Regolare

    Messages:
    381
    Jorhat, Assam
    These can be the chief reasons behind this sudden powerloss problem:
    1. Faulty EGR valve
    2. Leak in the turbo hoses.
    3. Bad fuel
    4. Some issue with the fuel pump.

    The engine-scanner cannot detect this issue. You need to check and rule out the above possibilities one after the other, until you reach the culprit.

    In my case, it was the faulty EGR valve. I now drive around with the EGR disconnected.
  6. Deepak

    Deepak Regolare

    Messages:
    456
    KA-30
    Bengaluru
    Punto Evo 1.3 90 HP
    @Rituraj : glad to know u have found a solution finally :)
  7. PKMohan

    PKMohan Amatore

    Messages:
    59
    Bangalore
    Glad that there is a solution. I have encountered only 2-3 times so far and the last one was 3-4k kms back. Hope those issues were related to fuel quality.

    Regards
    PKMohan
    Deepak likes this.
  8. shivraj5624

    shivraj5624 Amatore

    Messages:
    120
    Belgaum, Karnataka
    belgaum
    Linea 1.3
    Hello all. I am here to tell the same tale of loss of power. Well , Rituraj has summed up well and the EGR vavle adds on to the issue here. Off late even i ad the issue of sudden loss of power which especially happens on a slightly uphill road when i'm cruising fast. the frequency of the issue had been always increasing.
    Recently i went to the service station (sutaria Fiat ,belgaum) immediately when the power loss was felt. I didn't switch off the engine. My car (linea MJD) was connected to a PC where it showed the malfunctioning of Accelerator and clutch sensor fault. Left the car for 2 days, where all possibilities were ruled out. Fuel was tested and was not at fault,egr was recently cleaned. Later the accelerator and clutch sensors were reset and given back to me. i'm happy to say that the issue has not arised now for last 1k km atleast. fingers crossed. i hope my car is out of it now.
    VIJENDRA SINGH and Deepak like this.
  9. Deepak

    Deepak Regolare

    Messages:
    456
    KA-30
    Bengaluru
    Punto Evo 1.3 90 HP
    @shivraj5624 : good to hear. but resetting the A and C sensors is enough? if it's malfunctioning shouldn't it be replaced?
    How's the service @ Sutaria fiat belgaum ?
  10. shivraj5624

    shivraj5624 Amatore

    Messages:
    120
    Belgaum, Karnataka
    belgaum
    Linea 1.3
    Car is now under EW . Also i just wanted the issue to be solved , what ever the things might be.The issue has not recurred again . Will have to wait and watch.
    Ya,Sutaria is too good. The works manager Mainuddin has a lot of fiat's technical knowledge. so u need not worry at all about the reliability.
    Deepak likes this.

Share This Page