1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

steering wheel vibrations.. a lot of feedback above 90kmph

Discussion in 'Tyres & Alloys' started by harryaviator, Nov 11, 2014.

  1. harryaviator

    harryaviator Regolare

    Messages:
    341
    kochi
    kochi
    Linea 1.3
    the tires have been replaced around 25000k
    total run till date is only 14000k. done 3 rotations in between including balancing. balancing also done with alignment...not pulling to any side
    anyways, with majority suggesting that its an issue with the balancing, will again get it done and see..

    thanks a ton for the suggestions. just wanted to rule out the possibilities of a major component change as the car is in its last year of extended warranty..
  2. Kaushik Talauliker

    Kaushik Talauliker Novizio

    Messages:
    41
    Margao Goa
    Margao - Goa
    Punto Evo 1.3
    I never knew u changed ur tires at 25000k.
    What was the reason to change you tire so early? May be i can give you suggestion after that.
  3. whitepunto76

    whitepunto76 Regolare

    Messages:
    267
    Bangalore
    @harryaviator:
    Option 1: Change the combination of tyres & rims. Look out for slight bent rims or uneven surface of tyres. Go for Road Force while balancing wheels and check for vertical/horizontal angles and the weight each wheel takes. More the weight, its probably the culprit.

    Option 2: Swap the wheels from back to front in cross and take a drive. Need to check out combinations

    Option 3: Get the suspension parts checked in FASS. Probably the tie rod of left & right front sections. Also, have them check for Caster/Camber values for confirming they are correct.

    Go for good/reputed tyre alignment shops.

    Let us know what was the outcome.
    prabhjot and harryaviator like this.
  4. Vijairaj

    Vijairaj Amatore

    Messages:
    55
    Chennai
    I had this issue too and the reason was slight bend in the front wheel alloys. I moved the back wheels to the front and the problem went away! you might want to check if the front wheels have any bend...
    prabhjot and harryaviator like this.
  5. harryaviator

    harryaviator Regolare

    Messages:
    341
    kochi
    kochi
    Linea 1.3
    just did the same.. problem resolved. thanks a ton for the help guys..

    problem - one alloy(front right slightly damaged..)
    prabhjot likes this.

Share This Page