1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

Steering wheel audio controls not functioning properly.

Discussion in 'In Car Entertainment' started by Ahamed Beig, Nov 2, 2012.

  1. Ahamed Beig

    Ahamed Beig Novizio

    Messages:
    39
    Bangalore, India
    .
    Grande Punto 1.3
    Hey Guys,

    I am not seeing any display for wheel audio control through steering. It is happening since last 4 days, though USB is connected.

    Earlier, I could able to browse the folders in the USB and play the songs through the display by operating steering wheel functions . Now, I don't see any display. More over, the steering wheel functions work some times, but the songs are shuffled and I am not able control, as I used to do earlier through the display.

    Please guide me if I need to take the car to service station or I can fix it by myself through settings.
    (Attached image is for reference)

    Thanks.
    Beig

    Display.JPG
  2. vIjAy_kHaSa

    vIjAy_kHaSa Esperto

    Messages:
    1,352
    Panchkula
    Are Steering controls working for Radio FM and CD.
    Try removing -ve terminal from battery if error would be in Blue N Me system it will be solved if it doesn't you would have to visit ASS to get the wiring checked.
  3. Ahamed Beig

    Ahamed Beig Novizio

    Messages:
    39
    Bangalore, India
    .
    Grande Punto 1.3
    Steering controls works fine for Radio ad CD.

    - - - Merged Post - - -

    Will there be any danger if I remove the -ve terminal of the battery by myself. Should I take any precaution before doing it?
  4. sdp1975

    sdp1975 Amatore

    Messages:
    206
    Bangalore
    Just remove the ignition key first and then disconnect the -ve terminal of the battery. I've done it several times - nothing to worry about.
  5. Ahamed Beig

    Ahamed Beig Novizio

    Messages:
    39
    Bangalore, India
    .
    Grande Punto 1.3
    Okay.

    I remember now, similar problem had occurred a year back. Then, I showed it to the service guy. he fixed it. When I asked how did he fixed he said, he remove the battery connection and re-connected again. That time I did not took it seriously, and I thought may be he is kidding.

    Now it is like this is how it works. (Like in a system problem, sometimes we re-start).
    I will try and if there is any problem then I will post it. I have scheduled service due in this month that time I will show at the service station.

    Thank you for the inputs.
  6. Ahamed Beig

    Ahamed Beig Novizio

    Messages:
    39
    Bangalore, India
    .
    Grande Punto 1.3
    Thank you all. Dis-connecting -ve terminal of the battery and re-connecting it worked.

    Best Regards,
    Beig

Share This Page