1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

steering oscillation at 70 km/hr

Discussion in 'Technical' started by Udeept, Jun 22, 2013.

  1. Udeept

    Udeept

    Messages:
    3
    Delhi
    hi,

    I have a fiat Grande Punto ( dynamic) 2010. the problem i am facing is that when i hit 70 km/hr the steering wheel of the car starts oscillating ( moves from left to right back and fro) i took my car to the service center many times... but the problem could not be rectified. i also got the front shockers changes, the alloys, the tyres just to get rid of the problem , but all in vain. have been taking my car for many wheel balancing and alignment centers but the problem remains. i also got the tie roads, mounts and the the arms changes just incase but all in vain. the oscillation is so bad that the i dont even feel like driving the car anymore. the fiat ppl have not been able to diagnose the problem. the car was taken to ABS motors gurgaon, Dhingra mOTORS gURGAON, kASHYAP fIAT but none cud fix it. recently some one told my that the problem might be with the steering column bush kit. just wanted to know if that can cause such oscillation .

    Also i recently recalled i started facing the problem once i got the front wheel hub and bearing changed . last year. although when i asked the fiat ppl to check if there was something wrong with the hub and the bearing ... but they said that its absolutely fine.

    I am in a big fix. would be highly greatful if you guys here can help me find the bug and get it fixed.

    Regards, Udeept
  2. vIjAy_kHaSa

    vIjAy_kHaSa Esperto

    Messages:
    1,352
    Panchkula
    If the problem started aftre hub and bearing replacement get them checked.
  3. Udeept

    Udeept

    Messages:
    3
    Delhi
    well thanks vijay! will get it replaced again, although a couple of weeks ago i got it checked at ABS motors, the technicians told me its absolutely fine.
  4. Surya

    Surya Superiore

    Messages:
    930
    Namma Bengaluru
    How many kms your punto has run ?
  5. macky

    macky Amatore

    Its a famous problem, I think many Puntos have it but at different speed range!! mine gives that mild oscillation at around 100-110KMPH, I think it is something to do with the design itself of what ever component is causing this(steering rack, suspension, i am not sure), most of the owners tend to ignore it, I am sure even in your case it will disappear say after 80 or 90KMPH.
    Last edited: Jun 24, 2013
  6. Have tried getting alignment done at a HD center? i too own 2010 model but i have not issues mentioned by you.
  7. vIjAy_kHaSa

    vIjAy_kHaSa Esperto

    Messages:
    1,352
    Panchkula
    Does your Punto have aftermarket alloys either 98 PCD or 100 PCD, if yes get get spigot ring/ hub ring to get rid of vibrations. Are there any bends in your rims/alloys. My 3 alloys have bend and I get heavy vibration on steering at some speeds goes away if I increase or decrease speed a little.
    Try OEM alloys from TD Car of a dealer and see if vibration goes away.
  8. varin11

    varin11 Superiore

    Messages:
    821
    Mumbai
    Bombay
    Linea 1.3
    may be rack issue that's the last part left to be changed.I get steering vibration at low speed under 30 km/hr but my car is 4 year old and has done 73000 kms.
  9. Italia-Linea

    Italia-Linea Staff Member Janitor

    Messages:
    2,123
    Pune
    Its clearly the front hub issue. The front hub has a specific runout. During assembly in the plant the higher side of the runout on the hub is matched with the lower side of the brake disc so that its balanced.

    In your case seems the runout of the hub is not matched. Also the pressing of bearings in the hub is important. It should be done properly on the press and not by hammerring.

    Now since the issue has started, get the hub runout checked on a dial guage.
  10. Udeept

    Udeept

    Messages:
    3
    Delhi
    hi vijay... yes i do have after market alloy 100 pcd. but they are absolutely fine and have no problems what so ever. i have tried the wheels from a friends punto on my car and even then the oscillation happens while his car drives absolutely smooth with my tyre and alloys. so its clearly not a alloy / tyre problem. Although i really dont know what a spigot ring/ hub ring is. would it be available at the service center??

    - - - Merged Post - - -

    Hi italia. thanks for the advice. i am going to get the wheel hub and bearing replaced tomorrow. will update as soon as i am done. fingers crossed. :(:(:(

Share This Page