1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

Sluggish Linea MJD

Discussion in 'Technical' started by nishweth, Jun 10, 2012.

  1. gurjinder

    gurjinder Staff Member Janitor

    Messages:
    3,989
    Punjab
    I was experiencing symptoms such as jerky engine performance and pretty much no power till 3000rpm. On a hunch I tried an ECU reset by disconnecting battery even though I have always denied it as a placebo.

    The car felt much changed afterwards. It is still not 100% but the jerks are gone and power is coming on by 2000rpm. Maybe the ECU just needed to start afresh ?:confused

    So, give it a try. Nothing to lose.

    Cheers.
    I kept the battery disconnected for around 20 minutes. During that time the ignition switch was turned to "MAR" to remove any residual current whatsoever.
    1 person likes this.
  2. varunrtr

    varunrtr Esperto

    Messages:
    1,256
    KL-01/ TO
    Grande Punto 1.3
    I m also filling from IOC right from purchase..petrol and diesel !!!
    getting maximum mileage and smoothness from ioc only !!
    Last edited: Aug 3, 2013
  3. alt_f_in

    alt_f_in Timido

    Messages:
    5
    Kochi
    Same sluggish feel felt by me with my Linea MJD, low power, sometimes feary to even overtake, sometimes its like somebody is pulling the car from behind (like auto brakes or engine brakes are applied) while overtaking or zooming in. Tried rectifying with Hyson motors Kochi they checked up everything and said car is normal and Aadya motors bangalore they kept car for 2-3 days checked everything but said to drive and see i felt the same even the SA kept quiet he didnt comment anything other than "you test drive for yourself" as i had to move out of bangalore so took the vehicle. this is happening with me from 15000 kms now the car is done with 30000 and im now living with it.
  4. sriramr9

    sriramr9 Amatore

    Messages:
    211
    Chennai

    2012 Jan Model Punto MJD done 16500km on odo, car feels sluggish as like other members are feeling. could not external factors also matter to this problem ? air filter etc ?

    Disconnecting the battery is generally done by unplugging the negative terminal correct? which is covered by plastic, kindly confirm once.
    Last edited: Nov 2, 2013
  5. gurjinder

    gurjinder Staff Member Janitor

    Messages:
    3,989
    Punjab
    Get all the intercooler hoses checked.

    I only recently came to know that the intercooler hose has a small tear which has gradually widened. Now it sounds like a pressure cooker releasing steam when the rpm crosses 2000. Will update after replacing the hose.

    Cheers.
  6. sriramr9

    sriramr9 Amatore

    Messages:
    211
    Chennai
    Thanks, Request you to please post a picture of the damaged part and replaced part ? esp the "hose"
  7. gurjinder

    gurjinder Staff Member Janitor

    Messages:
    3,989
    Punjab
    In my case, the pipe labelled "outlet tube" is ruptured.
    Last edited by a moderator: Aug 16, 2014
  8. vj_v1

    vj_v1 Superiore

    Messages:
    933
    Hyderabad
    As you see in the image, the outlet hose comes in 3 pieces. The middle one is hard plastic and nothing happens to it. The longer rubber hose got cut the first time and the next time it was the shorter one on my 90HP.

    I suspect the current hoses got a tiny cut again, Need to get it checked. I get a slight hissing sound when revving high and my car does not reach the max kmph it was capable of in the past these days when i intentionally tested.
    Last edited: Nov 2, 2013
  9. Sam

    Sam Amatore

    Messages:
    168
    Mumbai
    + 1 to guruji on the intercooler hose. I just got mine "Outer Hose" replaced yesterday and man I noticed the difference! I never felt my 75 HP accelerating this mad. In any gear when I gave ample throttle I sunked in my seats :D Engine now sounds much relaxed, earlier at around 2k rpm engine used to sound like a tractor :D Also the mechanic noticed a thing which to me appeared strange. Engine oil was leaking through the hose sleeve. These hoses generally carry air to engine's inlet manifold then why oil? Nonetheless I checked oil levels twice in dead cold condition and its all fine.

    Other reasons for poor pickup on an MJD may be.

    1) Clogged air filter. I would suggest a replacement.
    2) You made ECU believe that you are sedate driver :) Take your beast in open (highways) and give it a good spin.
    3) Bad diesel
    4) Clogged Fuel Filter, take examiner's help
    5) Clogged Injectors, take examiner's help
    1 person likes this.
  10. rpm19050

    rpm19050

    Messages:
    41
    Delhi
    explain please? fiatecuscan will help? which parameters are to be focused on?

Share This Page