1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

Race Chip installed and engine not starting

Discussion in 'Engine and Drivetrain' started by moksh, Aug 12, 2013.

  1. moksh

    moksh Regolare

    Messages:
    347
    Mumbai/Germany
    Linea 1.3
    Hey guys please help me today i have installed race chip pro2 1.3 Linea MTD and after that engine is not starting i have tried 2-3 times still not starting what should i do anyone else faced this problem Thankyou
  2. PatchyBoy

    PatchyBoy Esperto

    Messages:
    2,438
    Bangalore
    Does the engine crank at all? What about other electrical in the car. Do they work? Have you tried removing the race chip, reconnecting everything as it originally was, and starting the car?

    Rajan
  3. moksh

    moksh Regolare

    Messages:
    347
    Mumbai/Germany
    Linea 1.3
    Everything Works after race chip is removed .Yes it cranks and everything works all electricals with race chip except engine
  4. Ganges

    Ganges Esperto

    Messages:
    3,121
    Driver Seat _/
    :
    Grande Punto 1.3
    tried to contact with race chip customer care ? the product is for linea only ?
    1 person likes this.
  5. gurjinder

    gurjinder Staff Member Janitor

    Messages:
    3,989
    Punjab
    You have your answer :)
    1 person likes this.
  6. varunrtr

    varunrtr Esperto

    Messages:
    1,256
    KL-01/ TO
    Grande Punto 1.3
    Had the same experience with race dynamics with my frnds linea... it was just a trial..the chip wasnt linea specific, it was just mentioned MJD, it was for swift/dzire...
    The same must be the case with you..contact their customer care and get it changed !
    1 person likes this.
  7. moksh

    moksh Regolare

    Messages:
    347
    Mumbai/Germany
    Linea 1.3
    I have Contacted Race chip they have asked for photos . and its for linea 1.3 multijet 100% as it is also written in invoice. i have connected scanner and it says error as "P0641 Sensor Power Supply 1"
  8. pioneeraaron

    pioneeraaron Superiore

    Messages:
    716
    Mulund/Mumbai
    @moksh

    Send that chip back and ask for an refund and get your chip remapped by Kiirus :)
  9. moksh

    moksh Regolare

    Messages:
    347
    Mumbai/Germany
    Linea 1.3
    Not Required Car started this morning ......I know what mistake i have made :) Remapping Not In MY plan
  10. PatchyBoy

    PatchyBoy Esperto

    Messages:
    2,438
    Bangalore
    Good to hear that. Why don't you post a "How To", so other members opting for these chips can benefit?

    Rajan

Share This Page