1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

Punto's Clutch depressed, again!!!

Discussion in 'Electrical Systems' started by adigabnp, Nov 13, 2012.

  1. adigabnp

    adigabnp Amatore

    Messages:
    65
    BengaLooru
    BengaLooru
    Grande Punto 1.3
    Hi folks,

    My Punti has completed 33,000 kms in the past 14 months and I have the "clutch depress" issue back to haunt me again.
    The 3rd free service was completed at 28,000 kms, a couple of months back.

    Here goes the brief history to the issue:

    Punti has been my first 4-wheeler vehicle that I bought. The day after I brought her, I saw an issue wherein the clutch gets depressed and does not come up, when I press it try to change the gear. Since I was new to 4-wheelers, I assumed that my driving habits were the reason for it. A week later, even my friends who drove my vehicle saw the same issue. Sooner, I too faced this issue multiple times, especially while overtaking etc.!
    I realized that it's the clutch that had an issue and not my driving habits. This was intermittent, though.
    I took her to the TASS [< 250kms driven vehicle] and checked with them. Since the issue was intermittent, they always sent me back with some explanation or the other!!! :(

    I then sent an email to Fiat India after which I got some attention from TASS who came to my workplace and picked up my vehicle and did a thorough check. They replaced a clutch shaft/rod [I am not sure, what exactly! :confused:] after which I never saw this issue again until last Sunday, when I was in a remote village in U.K. district of Karnataka and my friend witnessed this issue, again! :eek:

    Present issue:
    The issue was intermittently persistent throughout the journey! It persisted only when my friends drove it. At one point it persisted so much that we had to meet a local mechanic since there are no TASS centers available nearby.
    We met a local mechanic who told us that it needed some greasing to avoid the friction causing the issue. After the greasing, the issue was not seen, though my friends always struggled to shift gears, unlike me!

    Next action:
    I am now confused what should I do now. I am not sure if any existing Punto owners have seen similar issues!
    Can I ask TASS for replacing Clutch pad etc?
    Kindly advice.

    By the way, I have clicked a couple of snaps when the clutch remained depressed.


    P.S.: I call my Punto as "Punti"! ;)
  2. varin11

    varin11 Superiore

    Messages:
    821
    Mumbai
    Bombay
    Linea 1.3
    just get the clutch slave cylinder checked.they were the culprit in most of the cases.
  3. adigabnp

    adigabnp Amatore

    Messages:
    65
    BengaLooru
    BengaLooru
    Grande Punto 1.3
    Thanks Varin11. I will get it checked in TASS over the weekend.

    - - - Merged Post - - -

    Here goes the pics at the instants when the clutch remained depressed!

    DSC_0563.jpg DSC_0564.jpg
  4. adigabnp

    adigabnp Amatore

    Messages:
    65
    BengaLooru
    BengaLooru
    Grande Punto 1.3
    Today I checked with the service engineer in Concorde Motors and he has promised to take a look at the issue seriously on Monday.

    Mods and others - Any advice or recommendations?
  5. rishike007

    rishike007 Esperto

    Messages:
    1,416
    Mumbai-Pune
    Pune- Mumbai
    Grande Punto 1.2
    As per your picture, your clutch pressure plate is gone. But don't replace only this, replace the complete set i.e. clutch plate & pressure plate with bearing.
  6. caffeineam

    caffeineam Amatore

    Messages:
    217
    Mumbai
    Here's mine from Jan 2011 when the clutch failed on the road. There's apparently plastic piece in the assembly that they have since replaced with a metal piece. No issues since then.

    27012011043.jpg
  7. Shadowfax

    Shadowfax Regolare

    Please check if you have a plastic CSC

    Sent from my GT-I9100 using Tapatalk 2
  8. adigabnp

    adigabnp Amatore

    Messages:
    65
    BengaLooru
    BengaLooru
    Grande Punto 1.3
    Hi folks,

    I recently had a complete clutch failure, wherein the clutch went completely dead. On depress, it never came back. If pulled manually, the same repeated.
    This is unlike what had happened earlier, wherein the clutch got engaged after the intermittent "depress" issues!

    This time, the issue was with the MASTER Clylinder! I had the "SLAVE" cylinder replaced when my vehicle was 1700 kms old. No she is around 40000kms old!

    I checked with the SA if any other "cylinder" also needed replacement [Pun intended]! He obviously said, "No!" :)
  9. caffeineam

    caffeineam Amatore

    Messages:
    217
    Mumbai
    What was the reason for the failure? Cracks in the cylinder, leaking pipes, broken piston?
  10. adigabnp

    adigabnp Amatore

    Messages:
    65
    BengaLooru
    BengaLooru
    Grande Punto 1.3
    It was supposedly the leakage!

Share This Page