1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

Punto Horn issue

Discussion in 'Electrical Systems' started by nand_nand, Dec 26, 2012.

  1. nand_nand

    nand_nand Amatore

    Messages:
    74
    Bangalore
    Grande Punto 1.3
    Hi All,

    I am facing a weird issue on my 2012 Punto MJD where the horn stops working at times. My car is hardly 6 months old with just 7k kms completed :-( I tried to figure out by doing some tests where during the day time the horn seems to be working fine without any issues, but the sound was not like before it has reduced. When I am driving in night with just head lights on sometimes with fog lamps on, it stops working. How much ever times I press I am not able to hear the horn sound. I am not sure whether the horn unit or the switch on the steering wheel is causing the problem or some electrical wiring is causing any issue? :-( My car is just 6months old. Has anyone faced similar problem before? I wanted to contact TFI before asking TASS on this issue.

    Thanks,
    Nanda
  2. dhans4all

    dhans4all Amatore

    Messages:
    156
    Chennai
    better have a visit to TASS and get it checked, Battery might be an issue but still if you dont have any problem in starting the vehicle then it needs to be checked.

    sure it is gonna be a minor issue, please get it checked with TASS immediately.
  3. Viny

    Viny Esperto

    Messages:
    1,742
    :)
  4. nand_nand

    nand_nand Amatore

    Messages:
    74
    Bangalore
    Grande Punto 1.3
    Thanks for the reply. I will check with TASS. My observation was incorrect. Even during day time the horn does not work. Even now I checked the horn it was not working. I do not have any issues in starting my car, head light, fog lamps works perfectly fine when the car is idle. I am not sure about this issue :-(

    - - - Merged Post - - -

    Hi Viny,

    Thanks for the reply. I checked the post but you have mentioned that the bottom switch creates problem, but for me it works at times and sometimes it does not work. I am not sure whether it could be electrical problem. :-( My car is just 6 months old so whether I will have warranty for the horn. Could you please tell me what all I need to check on horn perspective so that I can ask the TASC to check the same.
  5. apt

    apt Timido

    Messages:
    24
    vadodara
    Yes, you are absolutely right.
    I am facing the same problem but in addition MY GP's headlight are also stop working frequently. I don't know where it goes on or off. Even i found there is only a single horn instead of dual horns that's why it sounds so horrible when it works.
    My GP MJD was 6 months old and drived 9000+ kms had some very weird problems.
  6. dhans4all

    dhans4all Amatore

    Messages:
    156
    Chennai
    I had this problem in my previous Palio and the issue was with the ring connecting the horn switch and after cleaning the ring it was working fine.

    probably it might be like Viny's switch pad issue then, please check with TASS and update it.
  7. nand_nand

    nand_nand Amatore

    Messages:
    74
    Bangalore
    Grande Punto 1.3
    Did you enquire with TASC regarding this issue?

    -nanda
  8. naveen2cool

    naveen2cool Superiore

    Messages:
    646
    Chennai
    Nanda,

    You are lucky that yours went kaput after 6 months :D Mine started giving problems on the third day after delivery. It used to work sometimes and doesn't work all of a sudden. Showed the same symptoms as yours. I didn't worry about it. The horns in 2012 Puntos are so weak. They have only one horn. I didn't take my car to TASS for fixing but took it to a nearby acc shop and replaced my horn with ROOTS wind tone. And no problems faced henceforth after that and horn is living happily ever after.

    pammmmm pammmmm:redcar
    Last edited: Dec 27, 2012
    1 person likes this.
  9. nand_nand

    nand_nand Amatore

    Messages:
    74
    Bangalore
    Grande Punto 1.3
    Hi Naveen,

    So is this problem with the horn or the switch in the steering wheel?
  10. naveen2cool

    naveen2cool Superiore

    Messages:
    646
    Chennai
    I guess it was a problem with the horn. They didn't touch the steering wheel at all while fixing the ROOTs horn. They used a relay and installed the new horn. Guess it should be the same issue with your horn as well. I was a lazy to take my car to TASS and I didn't like the OEM horn anyways. If you are keen on changing the horn go right ahead to a good accessory shop and ask them to check the power output to the OEM horn when the horn pad is pressed and if it is all right you can install a new horn of your choice. If not book an appointment with TASS and fix the existing horn under warranty.

    In the end as your car is just 6 months old and there should not be any issue with the horn pad. So no worries.

    btw where are you from Nanda?
    Last edited: Dec 27, 2012

Share This Page