1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

Punto feeling heavy...

Discussion in 'Technical' started by adigabnp, May 28, 2012.

  1. scottzinne

    scottzinne Timido


    I agree with the heavyness feeling. few Days back I got My Linea's 60K service done. Yesterday my wife said you car is sounding like old Ambassador.

    It feel very heavy, & engine also sounding pretty high. I also noticed lots of black smoke comes when turbo starts spooling up.
    Same thing happened in past also, my father drove car & his instant reaction was" Kitni thass chal rahi hai" " How heavy its feeling"

    Anyways today i will be visitng TASS will update you soon.
  2. vIjAy_kHaSa

    vIjAy_kHaSa Esperto

    Last edited: Aug 13, 2012
  3. bhai

    bhai Esperto

    Grande Punto 1.3 90 HP
    Got 2nd service done from Sanya Motors, Aurangabad.

    Problem of heavyness solved. SA told vaccum pipe was bent.
    So engine was not getting proper vaccum.
    I pray that this statement should be true. Coz I observed that tata guys do often some temporary remeady. & due to temporary remeady,car runs well only for some thousand km& after that problem again starts.
  4. Chaos

    Chaos Regolare

    Thats good to hear the issue is not there anymore.. :drinks

    As to identify the issue, what I understand from reading the thread is that it sounds more like carbon deposits and the drive by wire fuel mixture values in the ECU..

    You say your friend up shifts above 2k so that suggests some of the carbon deposits in the system might have been cleared also the throttle response must have changed... (improved :devilface)

    If the "heavy-ness " returns try disconnecting the terminal for like 5 odd minutes; reconnect and drive on an empty road (or go for a late night drive when the roads are empty giving you space to rev) for a few kms / 5 mins upshifting around 2.5k - 3k while being a bit aggressive with the throttle than you normally would. :redcar

    note: disconnecting the battery is optional.. after the drive if there is no change.. go ahead and disconnect and repeat..

    If its solved then you know briefly there is no tech issue ATM... ::T
    just some carbon..

    The TASS dont forget, they are just lazy to disconnect and reconnect the battery :hit
    Last edited: Aug 29, 2012
  5. My MJD Active Punto exhibited a turbo loss for the first time yesterday. Mileage covered so far is 39000 kms.
    While coming from back from my home town i slowed down for a speed breaker and then accelerated. Even with the full pedal punched there was no power at all, it became all heavy suddenly. RPM was not at all going above 2000 in second gear.. I released the accelerator and started again, this time the turbo kicked in at 2200 RPM but the engine was not that smooth running. After this incident i see a lot of turbo lag and the there is no smoothness in the engine and sweet sound of turbo. One thing to note is that the tank was filled completely in the same fuel station which i regularly go for [IOC].
    I will try disconnecting the terminal today and see. Note that i am using a K and N air filter which was cleaned just 1000 kms back.
  6. bhai

    bhai Esperto

    Grande Punto 1.3 90 HP
    Bad news! Again car is suffering of heavyness issue,poor low end torque.
    Performance is so bad that I have no daring to start ac even on flat road.

    SA told he will clean & check egr valve.
    Last edited: Oct 27, 2012
  7. adigabnp

    adigabnp Amatore

    Grande Punto 1.3
    Hi Chethan,

    I am not pretty sure about what might be the issue. However, 39000k hints me that your Punto is nearing the 4th service [assuming the 10k service interval] unlike Fiat's recommendation of 15k interval.

    Time for TASS!? ;)

Share This Page