1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

Punto Air conditioning problem

Discussion in 'Technical' started by amit.thakkar, Jan 7, 2012.

  1. Hi guys,

    I have 1.2 active petrol punto. have driven over 45k now in 2.5 years.

    recently, i am having some problem in a/c. i get some bad smell - its not coming continuously but say 3-5 mins in 15-20 mins of period. i showed it to couple of local mechanics. one said that it could be because some dust might have jammed in a/c vents. he told me that entire system will have to be opened and cleaned up which would cost 3k including refill of gas. another told me to take to TASS.

    any idea whats wrong?
  2. VahanPujari

    VahanPujari Staff Member Janitor

    Messages:
    2,303
    Mumbai
    I also experienced the same. Sometimes, there is a foul smell which starts coming in. What I do is to remove AC recirculation mode i.e. allow outside air to come in. In a moment the foul smell goes away.
  3. varin11

    varin11 Superiore

    Messages:
    821
    Mumbai
    Bombay
    Linea 1.3
    get it cleaned.
  4. M A N U

    M A N U Amatore

    Messages:
    196
    Bangalore
    there are multiple threads on this topic kindly search , you will find the solution easily.MODS please do the needfull
  5. Thanks guys,

    will cleanup the system.
  6. Ganges

    Ganges Esperto

    Messages:
    3,121
    Driver Seat _/
    :
    Grande Punto 1.3
    Previously chilling(In Summer) was perfect at 16'C,but these days(In Summer) not feeling more chilling effect at 16'C.
    So what need to be checked ?
    (Please avoid discussion about sunfilms)
    Last edited: Mar 29, 2012
  7. theblack

    theblack Esperto

    Messages:
    2,188
    Bangalore
    My punto is a '09 model and black color car.
    Ive noticed that the AC is bit weak in the afternoons and pretty OK in the evenings and nights.
    I've always felt its on the weaker side only but all my tests have turned out to be negative. No leaks, AC gas is up to the mark.
    The air coming out of the vents when blower is set to '2' is about 5-7C .

    When i turn both the vents on the console to my side the AC is good but with only 1 vent its not all that great.
    Could there be a problem or is it just that I have a black car and the AC is not too powerful?

    NOTE :: I always set the AC to coldest setting and blower to '1'.
    All my above observations are based on these settings.

    - - - Merged Post - - -

    Forgot to ask, If i set the blower to 2 does it consume more fuel ?
    Mine is not ACC
  8. vIjAy_kHaSa

    vIjAy_kHaSa Esperto

    Messages:
    1,352
    Panchkula
    Its due to weak blower and less than optimal vent design steering blocks air going to driver.
    The AC's in Fiat cars doesn't circulate cold air through whole car to cool cabin, left & right side vents have almost nill airflow only the center vents have good flow and driver side flow gets blocked by steering (keep both hands on steering and left side hand would get chilled due to cold air). AC feels wonderful on passenger side

    Blower speed doesn't effect FE might be a difference of 0.1-0.3 kmpl at max
    Last edited: May 16, 2013
  9. theblack

    theblack Esperto

    Messages:
    2,188
    Bangalore
    yeah i've felt that vent design is very poor and most of the air is blown directly to the steering wheel.
    Its also nice to know blower speed does not affect FE because when i feel hot i will turn it up a notch next time onwards.
    thanks
  10. ronak agrawal

    ronak agrawal Timido

    Messages:
    3
    Pune
    Grande Punto 1.3
    I am facing the same issue with my Punto MJD 2010 model.
    The ac used to work sometimes whereas sometimes the blower used to refuse to start.
    I took the car to authorized Sky Moto fiat service center and they said the resistance is gone and the wiring has issues.
    I told them to fix it anyhow as Pune's temperature is very hot these days.
    They charged me 5.25k for the same and returned the car.... The very next day again the blower did not start like before, i again submitted the car. This continued for 3 times within a month and now its 4th time when my car's blower is not working at all.
    Escalated the same issue to
    service.india@fcagroup.com
    around 2 weeks back and the complain manager called me to say that the issue is with the blower as per the workshop.
    I am so pissed off on them, its been more than 10 days and they have not bothered to call back or reply even after calling them multiple times.
    Why should i spend money because of their blunder in identifying the issue? The call center guys are not ready to provide any senior guys's email ID yet.
    Can someone please help, what should i do now?

Share This Page