1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

Power Loss in tjet

Discussion in 'Engine Compartment' started by amit1agrawal, Feb 21, 2011.

  1. amit1agrawal

    amit1agrawal Amatore

    Messages:
    84
    Bangalore
    Hi All,
    I am experience a strange problem off late.
    When I am accelerating hard uphill in 3rd gear the power doesn't seems to be constant. There is a power loss every second a so.This keeps on happening and is more apparent when the
    gradient is higher. So the vehicle gives continuous jerks of low intensity as it pulls, loss of power, pull, loss of power, pull...
    I felt this first when returning from Wayanad in the Dec end but I though it is some temporary issue (maybe due to adulterated fuel).
    However, last Sunday I when to Beemeshwari where I was climbing on steep climb in ghat section.I put in second gear and when the car had enough speed, I put in third gear, press the accelerator; the car pulls for a second or so and then I hear a sound 'krrrrrr.....' from below the engine along with power loss. I had to downshift to second gear where the problem didn't happen. Again, yesterday from my trip to mysore and back I was feeling this intermittent loss of power whenever I was climbing up in 3rd or 4th gear.
    Does anybody has any idea on what could be the issue?
    Odo is reading 4600 and will get it checked in the first service.Waiting for my tjet manuals to arrive.

    Cheers
  2. Ravi

    Ravi Staff Member Janitor

    Messages:
    6,001
    Bangalore
    Grande Punto 1.3
  3. amit1agrawal

    amit1agrawal Amatore

    Messages:
    84
    Bangalore
    Thanks Ravi.
    In my case i can feel the loss of power when the I keep the accelerator in the same position.
    The Effect is like pressing and releasing the accelerator. Moreover, in the steep incline I heard a sound 'krrrr' along with this loss of power. It was like the turbo is suddenly gone.
    And Yes I do feel that the turbo dynamics has changed over the course. It maybe an effect of engine opening up?
  4. Italia-Linea

    Italia-Linea Staff Member Janitor

    Messages:
    2,123
    Pune
    can you please tell us the rpms at which this is happening?

    what rpms is it when you shift from 2nd to 3rd and what rpm is it as soon as you get into 3rd.

    on the steep there are various factors on a turbo car. rpm is the key on every turbo car. with accl in same position the rpm keeps falling if gradient keeps increasing and at certain point the turbo doesnt have enough gases to spin or it semi-spins. at this point you feel the pulsating power

    power - loss of power- power -loss of power.

    while climbing dont let the rpm fall down. keep changing gears.
  5. bhai

    bhai Esperto

    Messages:
    1,185
    Ahmednagar
    Grande Punto 1.3 90 HP
    If Turbo is working correctly,no need to change gears unless & until you don't remove your foot from throttle
    OR your motion does not cut.

    Means if you have N A car you have to press more throttle to maintain speed in Ghat section

    But if you have Turbo car,no need to maximise throttle to maintain speed in Ghat.
  6. tjetdriver

    tjetdriver Amatore

    Messages:
    160
    Bengaluru, India
    i agree with Itialia-Linea. can you give the rpms at which u were experiencing this problem ?
    the one i had put in the other thread as pointed by Ravi was a "perceived" feeling. there was nothing wrong when i got it checked.

    also one more question, if u change from 3/4 to 2 do you feel anything different ? is it only in the 3rd or 4th gear that u r experiencing it ?
    According to me, the 3rd gear has the best acceleration in the t-jet !! mine has also completed 4700 and not observed it so far.
    best is to get it checked instead of waiting for another 400 kms.. in the meantime get it serviced too.
    which part of town are u in ? my suggestion is to go to prerana-peenya. so far i have had my issues resolved with them.
  7. royj

    royj Esperto

    Messages:
    1,306
    Trivandrum
    This definitely looks like there isn't sufficient rpm for the turbo to spool. I tend to agree with the diagnosis by Italia-Linea. Keep the rpm sufficiently high.
  8. amit1agrawal

    amit1agrawal Amatore

    Messages:
    84
    Bangalore
    The following is when climbing the steep gradient.
    I didn't observe the exact rpm reading when this happened but I shifted from 2nd to 3rd when the engine was straining in the 2nd gear.I think the rpm would be close to 4k.Speed would be between 30-40.
    When I shifted to 3rd I pressed hard on the accelerator, rpm climbed to more than 3k as I was revving hard and the car was pulling well and going 40+.Then I heard a sound 'krrrr' along with sudden loss of power (not an intermittent one but a continuous loss of power).I pushed for more throttle but it didn't help.I had to downshift to 2nd as the car could have stalled.

    Now with the accelerator in the same position lets say when climbing a non-steep gradient (there are many on Bangalore-Mysore highway), the car pulls-loss of power-pulls-loss of power.... when the accelerator is in the same position.I tried pushing the throttle more but it didn't help.And I have started observing this post dec end only.It was not there earlier.
    I am waiting for tjet manuals so that I can give it for service ( have raised a complaint with Fiat for this).

  9. It's an issue nevertheless did you try a different fuel supplier after you have noticed this power loss. Does your turbo spool at around 1800 rpm? If yes, I dont think it would be an issue with the turbo spool at 3rd unless your RPM is below 1800 or so and trying to lug
  10. amit1agrawal

    amit1agrawal Amatore

    Messages:
    84
    Bangalore
    I have tried Indian Oil, HP and Shell post dec. I normally use Shell only.Turbo spools in from 1500+ onward.I feel it spools in earlier now then when i took the delivery.
    This feeling could be because engine is opening up.

Share This Page