1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

Possible T-Jet acceleration issue : Causes ?

Discussion in 'Engine Compartment' started by puchoo, Apr 25, 2014.

  1. puchoo

    puchoo Regolare

    Messages:
    271
    Delhi / Shimla
    Hi folks,

    I have this feeling that the car is not accelerating as quickly as it should , the first time around i was right , there was a loose turbo pipe. Now i know the turbo is kicking in but it just feels a bit slow.

    Firstly the trademark "push" at 1700-1800 RPM is very subdued , secondly i feel that the engine RPM's might not be climbing as quickly as they should but i am wondering if this is more in my head or in actual.

    The folks at the workshop have run the scanners , checked physical connections and all is good.

    During the time the car was the the workshop for repairs from the accident i have they checked everything again and told me no problems were found with regard to the acceleration , i took the car back but clearly telling them that i will get back to them.

    I drove for a few days but was still not satisfied , so got the airfilter changed - nothing , then gave them the car again for a whole day to diagnose it. The ran the scanner again , did not find anything , checked the pipe fittings and the spark plugs but thats it. I drove two other jets while there as well to compare but they had each done about 40,000 Km's so not a very balanced comparison.

    I am wondering if they are checking everything that they should be , they basically seem to put all their faith in the scanner and if no error codes are found decided all is ok with the car , but is that all they should be doing - what about things like the Throttle sensor , MAF , MAP - should those items not be checked as well?

    I am planning to send an email across looping in Fiat as well now asking them to tell me what the standard operating procedures are to check acceleration issues on the Jet - they had a 7 step process defined in a chart which i happened to see for the 1.3 while i was there at the workshop.

    Any directions on what could be possibly wrong , what should be checked would be immensely helpful. To sum up symptoms again

    Slow acceleration
    Sometimes i feel that the turbo comes on but not with the same pressure as it did
    Sometimes i feel that it does not come on at all , or it actually really gives the "shove" well in excess of 2000 RPM's which should not be the case.

    All these problems started after i gave the car for the first servicing , where nothing major was done except i wanted the engine oil changed instead of it being topped up.
    Last edited: Apr 25, 2014
  2. pabhishek

    pabhishek Esperto

    Messages:
    1,379
    Oslo
    Pune
    Linea T-Jet
    Please try driving some other TFI'ans TJET or a test drive TJET, this would clear doubt if its only in mind. I too initially felt that my Jet's acceleration is missing/I am missing that 'boost'; but once I clocked near around 3k, It all seems well. I am able to notice the difference now.

    All the best!
  3. Ravi

    Ravi Staff Member Janitor

    Messages:
    6,001
    Bangalore
    Grande Punto 1.3
  4. Scorpioman

    Scorpioman Novizio

    Messages:
    26
    India
    Puchoo, when I was checking reviews on the T-Jet I came across a post either here or on TBHP where someone quoted a similar issue. Someone mentioned that the ECU kinda gauges the way you generally drive and re-sets to that. The suggestion given there was either drive hard for about 25 KM and it will come back to normal or disconnect the battery for about 10 minutes and then re-connect and it should be good.

    As weird as it sounds, nothing like giving it a shot. If you do try it and it works, please update us as well. The beast that the TJet is, is no fun when you do not feel the acceleration when you want it.
    Last edited: Apr 25, 2014
  5. puchoo

    puchoo Regolare

    Messages:
    271
    Delhi / Shimla
    Drove what was available at that point , i am at almost 8.5k now so.....

    I did that prior to putting up this , but thanks anyway for the reference , i was hoping to get "jet" specific advise..

    Will do , getting a distance of 25Km's in the city in hard driving mode is next to impossible really , even in high rpm - low gear scenarios but will give it a try!
    1
  6. rsinfo

    rsinfo Regolare

    Messages:
    422
    New Delhi
    Take it out for a spin late at night. That way you can cover 30-40 km smoothly without driving aggressively.
  7. puchoo

    puchoo Regolare

    Messages:
    271
    Delhi / Shimla
    Will try and take her out for a spin this weekend , but in the event that it does not help what does one think the main culprit or possible culprit could be - and in terms of FASS checking have they done a good job or not , or they should have checked the items i mentioned?
  8. 5u3zEr0

    5u3zEr0 Regolare

    Messages:
    390
    Madras
    Linea T-Jet
    Hi Puchoo, I got my Tjet a month or two after you got yours, I think. I read your posts when you were contemplating buying this car and just after you bought it. So to read about this acceleration issue could be quite heart rendering, at least to me if it had happened to my car. But this could also be just our brain giving us wrong signals.

    Though the Tjet has a turbo, the pull is very linear and you really don't feel it as much as in some other turbo charged cars. Second the turbo is very quite in the Linea, the only time I heard it prominently again and again was when the sound ricocheted off the mountains walls when driving up and down from Ooty. Otherwise I don't hear it at all.

    Did you try timing your car on a burst of acceleration and checking the 0 to 100 time? This could give you an idea if the car is under performing or your brain is over performing :).
  9. Navneet

    Navneet Amatore

    Messages:
    58
    Mumbai
    Mumbai
    Linea T-Jet
    Hey puchoo... Did ur issue occured after the accidental repair? If so, was the engine touched upon by them? If the issue is resolved let me know please , as I am also facing the same issue after the repair work. The car saved my life, but I am trying to save her too... She runs fines, but less turbo and picuk up... And after heavy speeding, check engine error crops up... (Turbo Pressure issue).. trying to troubleshoot the same
  10. puchoo

    puchoo Regolare

    Messages:
    271
    Delhi / Shimla
    Hi Navneet, no it happened after the first servicing which was a good 1 month or so before the accident , they topped up the engine oil in that and i think i had asked them to take car of some squealing sounds coming from the brakes as well.

Share This Page