1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

Oil Pressue Low Signal during first start in morning

Discussion in 'Punto 1.3 MJD 90 HP' started by sk.kashyap.92, Oct 12, 2016.

  1. sk.kashyap.92

    sk.kashyap.92 Amatore

    Messages:
    73
    Gurgaon
    Gurgaon
    Grande Punto 1.3 90 HP
    hi all,
    Need help urgently!

    I own a punto 2010 yr 90 hp and as on today i have clocked 1.72 lacs kms. Have been changing the engine oil at 10k interval after 1 lac odo.

    I have got the engine oil changed on 10.10.16 evening along with Oil filter. And from the very next day i have started getting the pop up on the odo "engine oil pressure low..... switch off engine...." during the first start in the morning.

    I have checked the oil level and its fine and the pop up appers only on the first start post which it disappears with no other engine warning sign on the odo. I have clocked around 350 - 400 kms approx since oil change.

    I am worried if there is any major issue in the car. Need experts advice on the same.

    Also would like to add that for the first time since the purchase i have used Helix 5W 40 and a maruti oil filter. I am in doubts if its because of it.

    Kindly advice. Your quick and valuable advice will be appreciated. Thanks in advance
  2. V. K. Pasupathy

    V. K. Pasupathy Amatore

    Messages:
    100
    Karur, Tamil Nadu, India
    Karur
    Grande Punto 1.3 90 HP
    Hi. Next time when you cold start your engine, try priming the pump a couple of times which is very simple. Turn on your ignition but do not start the engine. Let the lights goes off and wait for 20-30 secs. Repeat this for another time. After this try cranking the engine. If the low oil pressure message doesn't appear, then it is not a big problem to worry about. The issue could be as simple as the oil could gone a little thicker when cold and the oil pump requiring a warm up before it could freely circulate the oil. Having said that I'm amused a bit that you have used only the correct grade oil recommended for mjd yet having this issue.

    Also check the battery health. If battery is giving up, you may get a variety of MID messages in GP. Please do post feedback.
    sk.kashyap.92 likes this.
  3. sk.kashyap.92

    sk.kashyap.92 Amatore

    Messages:
    73
    Gurgaon
    Gurgaon
    Grande Punto 1.3 90 HP
    Hi,
    As mentioned i have used Helix 5W 40. I spoke to mr.op sharma from kashyap fiat today. He has taking about the faulty oil filter (i was given a maruti packing filter may be thats local) and possiblity of issue with oil.

    He also suggested that i use only selina especially when my car has clocked so much of kms. Only thing what i am not able to understand is whats the diff whether its selina or helix if grade is as recommended.

    He strongly recommended for immediate oil and filter change. The problem has started only after the oil change. May be issue is with oil or filter.

    I will surely check out what you have mentioned tom morning and update. Lets see if pop up comes or not. Thanks for the reply.

    I am worried about the engine hence i might go for oil change tom for my satisfaction if error pops up again.
    V. K. Pasupathy likes this.
  4. Deepak

    Deepak Regolare

    Messages:
    456
    KA-30
    Bengaluru
    Punto Evo 1.3 90 HP
    if you checked everything else and it's fine, last suspect would be oil pump. I had same issue and had to replace the pump.
    sk.kashyap.92 likes this.
  5. V. K. Pasupathy

    V. K. Pasupathy Amatore

    Messages:
    100
    Karur, Tamil Nadu, India
    Karur
    Grande Punto 1.3 90 HP
    A possibility with a limited probability as the messages are not appearing with every start.
    sk.kashyap.92 likes this.
  6. sk.kashyap.92

    sk.kashyap.92 Amatore

    Messages:
    73
    Gurgaon
    Gurgaon
    Grande Punto 1.3 90 HP
    Hi, I tried the process u suggested but the error appears still appers in morning for the first te. I will go for oil and oul filter and update.
  7. V. K. Pasupathy

    V. K. Pasupathy Amatore

    Messages:
    100
    Karur, Tamil Nadu, India
    Karur
    Grande Punto 1.3 90 HP
    OK. Please ask the service station guys to first check diagnostic trouble codes stored in the ecu before carrying out any work on your car.
    sk.kashyap.92 likes this.
  8. nkrishnap

    nkrishnap Staff Member Janitor

    Messages:
    1,900
    Bangalore
    Bangalore
    Linea 1.3
    Do you park the car on a slope? Say sloping from right to left of the engine bay? If yes, you will get this message at the first start in case its left stationery for a couple of days.
  9. anonexpr

    anonexpr Timido

    Messages:
    11
    Bangalore
    Bangalore
    Fiat Enthusiast
    Agree with @nkrishnap. Whenever I park the car sloping from right to left of the engine bay and leave it stationary for couple of days(like weekends), I get this message at the first start.
    sk.kashyap.92 likes this.
  10. sk.kashyap.92

    sk.kashyap.92 Amatore

    Messages:
    73
    Gurgaon
    Gurgaon
    Grande Punto 1.3 90 HP
    No car is parked outside my house and its flat surface.

Share This Page