1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

odo started blinking.

Discussion in 'Electrical Systems' started by deepam, Dec 11, 2010.

  1. Have dropped a mail to FIAT awaiting there response now. Guys I would advise everyone to get this Butyl Pad thing checked at the earliest.
  2. Have dropped a mail to FIAT Service keeping in CC Mangesh, Deepak, Ajay & Kiran. Got a standard reply after much ado from FIAT service as

    "Dear Sir,

    Thank you for your communication, we are in receipt of details.

    Matter is coordinated with our distributor/ dealer; we assure you concerns will be resolved at the earliest, you will be hearing shortly form Tata/Dealer end.

    Till then we request you to please bear with us."

    Now the wait begins.. :?
  3. VahanPujari

    VahanPujari Staff Member Janitor

    Hey there. I got Butyl Pad sticked in my Linea 2-3 months back by the very same Fortune Powai. Which SA did you deal with? Ashok?
  4. Amit its Makarand I am dealing with. He checked the TATA Siebel system and it seems there is no message or any note there stating about the Butyl Pad. Also there was no butyl Pad physically present above the A/C Air filter.
  5. Kindly Check whether the Time and Dates are set correctly. Turn the ignition off and back to MAR position in 15 Secs.
  6. Yup time and date are accurate. But will it cause Odo Blinking??

    In another development the SA at Fortune told me extended warranty bought on cars before 2010 the Blue & Me unit is not covered. Can someone confirm me this.
  7. kedarbendre

    kedarbendre Esperto

    MH 12
    I am also facing the ODO issue since last Saturday. Italia Linea, Tron and Me tried to resolved this issue but of no use. I will be taking my car to SC tomorrow for this issue.
  8. VahanPujari

    VahanPujari Staff Member Janitor

    Check with Ashok. He knows about it. In fact, he fixed Butyl Pads in my Linea in front of me. I even checked Butyl Pads. Its nothing but 2 thin strips (like Band Aid !!!)
  9. My Blue N Me was not detecting any fone, so I disconnected the battery for 10 minutes. After connecting, the odo started blinking and nothing happened whhen the Call Attend button on the steering wheel was pressed. The ODO blinked for a full day and Blue N Me was not working. So I again did the battery disconnect and after that the blinking stopped and Blue N me is working finer. Why not try the battery DC and RC exercise b4 going to the SC....
  10. Kedar do let me know once you get this resolved. I have tried disconnecting the negative terminal of Battery still no luck.

Share This Page