1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

odo started blinking.

Discussion in 'Electrical Systems' started by deepam, Dec 11, 2010.

  1. PaddleShifter

    PaddleShifter Staff Member Janitor

    Messages:
    2,697
    Chandigarh
    Grande Punto 1.3
    @Deepam- Did it stop blinking on its own or did you disconnect the negative terminal of the battery for 10 minutes?
  2. vIjAy_kHaSa

    vIjAy_kHaSa Esperto

    Messages:
    1,352
    Panchkula
    @ tjetdriver
    Blinking of ODO is not normal if dealer is not seeing into this problem kindly report the matter to fiat at service@fiapl.com
  3. deepam

    deepam

    Messages:
    82
    Mumbai
    I dont know how is stopped, but i think the service guys had disconnected the wires when i had given the car for service last week.
  4. Jotinder

    Jotinder Regolare

    Messages:
    308
    New Delhi
    Linea 1.3
    Guys, i think this will answer your question. I bought a new Linea diesal E+ in Sept 2010 and Odo was blinking from day one. I told my dealer(who by the way is my friend and is the biggest dealer in Haryana with 5 showrooms for TATA Fiat in Haryana) about this. He was told by Fiat to do Proxy Alignment by Fiat to Fix this problem. When they did Proxy Alignment, it started giving Airbag failure, but Odo stopped blinking. Then they were told by Fiat to change Airbag ECU. When they did it the airbag failure message stopped and Odo started blinking again. Then Fiat told them to change the whole MID (Whole ODO console), which didnt solve the problem. Then Fiat India contacted Fiat Italy and they send a New OS for ECU which solved the problem completely.

    Hence if you have ODO blinking problem tell them Fiat has problem with ODO blinking and Airbag failure. They can get new OS for the car from Fiat. This problem is with one batch of ECU of about 160 cars worldwide.

    One good thing about ECU upgrade, my car was more responsive and started giving better mileage by 1 km/ltr.
    :drinks

    Hope this helps everybody :)
  5. Viny

    Viny Esperto

    Messages:
    1,742
    :)
    Not again, one more issue by default in a batch of FIAT cars :(
    And you are lucky to find competent service team, majority of them are pathetic :(
  6. Jotinder

    Jotinder Regolare

    Messages:
    308
    New Delhi
    Linea 1.3
    Yeah you can say that, i am lucky that the owner is my friend ::T . But i was really happy with the way fiat india handled it. They were very eager to solve and were very quick with the replies. :wow

    As far as OS problem. Even Microsoft makes big error with billion$ spend on there OS development :hit . The main thing is are they ready to help and support and acknowledge the fault. Which i was mighty impressed with from FIAT :clap .
    1 person likes this.
  7. deepam

    deepam

    Messages:
    82
    Mumbai
    Ok, thanks jotinder a lot for your help, if it again starts blinking than ill for sure do as you suggested above.
  8. tjetdriver

    tjetdriver Amatore

    Messages:
    160
    Bengaluru, India
    I guess nothing worked and jotinder seems to have found the problem and solution.
    will need to take this up with the prerana @ bangalore. i dont how far it will be helpful with them.
  9. Aniket

    Aniket Superiore

    Messages:
    537
    Thane, Mumbai
    in owners manual sumwhere it is written that after we get our car from dealership after PDI and all we have reset our odo, it means when our car come from factory it runs around 50 to 100 kms on test track ,shiping and in PDI
    so we have to reset. after reset it vl run from 0
    its simple procedure to reset its same like we reset trip "A" and "B" u jus have to pree and hold button on right stalk

    just try to reset it now may be it was not done thats why its starts blinking
    dont knw it vl work o not but just try
  10. So far I drove 3000 KM’s and had this issue couple of times. Not sure how but now this is not there.

Share This Page