1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

odo started blinking.

Discussion in 'Electrical Systems' started by deepam, Dec 11, 2010.

  1. VahanPujari

    VahanPujari Staff Member Janitor

    Messages:
    2,303
    Mumbai
    Yes, Ravi. Exactly. They're Band-Aid kind of strips :p

    Tried to hunt for it's photo's in my ownership thread but seems I did not post it. Could only find the description here --->>>> Fiat Linea 1.4 FIRE Emotion Pack

    punto_emotion likes this.
  2. himanshu4886

    himanshu4886 Regolare

    Messages:
    261
    Ahmedabad
    Linea 1.3
    It happened to me once, I observed it while I was driving. The blinking stopped automatically after some time. I was thinking, that it might be an indication but couldn't figure out. Finally it became stable and it was a relief.
    Will enquire about the reason for blink from FASS
  3. gurjinder

    gurjinder Staff Member Janitor

    Messages:
    3,989
    Punjab
    I have been facing this Odo blinking thing on and off for the past one year++ o_O

    Never really bothered about it. Will get it checked if I go to FASS.
    jaggu916 and punto_emotion like this.
  4. punto_emotion

    punto_emotion Esperto

    Messages:
    1,245
    Bangalore
    Grande Punto 1.3
    I believe there are two types / issues tagged to odo blink. First, which Gurjinder mentioned blink + no effect on other functionalities. Second, blink + impacts on functionalities (Blue & Me going kaput, Battery going down etc).

    I have faced both types. There were occasions with only odo blink, where as previous one was associated with Blue & Me not working. Hence, it served as an indicator.
  5. acechip

    acechip Superiore

    Well, I have always been intrigued , and occasionally witnessed this blinking behaviour, which is seemingly random. And never got a good explanation for it. But now I attribute it to the emotional appeal of my Italian lass. She is entitled to her whims sometimes, isnt she?
  6. GP_Freak

    GP_Freak Amatore

    Messages:
    240
    Chennai/Madurai
    Chennai
    Linea 1.3
    All right fellaws, I join the bandwagon. The ODO started flashing for me too and I didn't give much importance. Then suddenly the fuel indicator dropped to Zero and the Amber light started flashing. Its been like that for nearly one month and 1500 kms. All these happened post 50 kms after my latest service :(:banghead::banghead::banghead:. Not sure whether there is any link, but my car had number plate light problem and asked to rectify during service, but the problem remains and more new problems.
  7. VahanPujari

    VahanPujari Staff Member Janitor

    Messages:
    2,303
    Mumbai
    Next time when ODO blinks, just check if your Blue & Me is working alright.

    There was this Blue & Me version 5.4 or 5.5 which had a bug causing ODO blinking.

    During service, they might not have connected the Blue & Me connector properly. It's in the glovebox somewhere under the Blue & Me box.
  8. GP_Freak

    GP_Freak Amatore

    Messages:
    240
    Chennai/Madurai
    Chennai
    Linea 1.3
    The ODO stopped flashing and now its the round orange/amber light which is flashing( Fuel Indicator doesn't work). But yes, I am having problems with Blue&Me, its just not taking in my voice commands properly. It was acting weird. But, music playable through USB, voice calls through blue tooth is fine, its only the damn voice command thing which is screwed up with respect to Blue&Me.
  9. VahanPujari

    VahanPujari Staff Member Janitor

    Messages:
    2,303
    Mumbai
    Looks like loose connection issue - may be an after effect of the service. Better to show it to FASC.
  10. alapverma

    alapverma Timido

    Messages:
    2
    Nashik
    Nashik
    My b&m is nt working. Odo blinking.
    SA traced the fault to b&m and needs to replace it. Today i will visit the future cars here in nashik to get the same replaced.
    No body knows the reason behind b&m getting kapoot.
    From the forum i learned about the butyl strips. I will get that checked.
    Just incase if at all i dont have then who bears the cost of b&m unit.
    Mine linea is 4.5 yrs old and 27000 km run. (Out of warranty)
    I never recieved any call frm fiat for refitting of butyl strips.

Share This Page