1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

Need Help on DIY

Discussion in 'Electrical Systems' started by akarparekh, Aug 25, 2014.

  1. akarparekh

    akarparekh Timido

    Messages:
    4
    Mumbai
    Hi Guys,

    I have been facing some problems with my Linea, Purchase in March 2009 Linea Emotion Pk (Petrol)

    1. Speedometer display not working
    2. Blue & me not working
    3. None of my blaupunkt systems working and its stuck on to a radio station. cant change the station or mode (CD, AUX, 1,2,3,4,5,6 etc)

    For blue & me
    1. I got the blue & me chip out from the glove box and cleaned it.
    2. Removed the -ive batter connector to reset it.

    Still not wokring.

    Appreciate your help.

    Regards,
    Akar Parekh
  2. akarparekh

    akarparekh Timido

    Messages:
    4
    Mumbai

    Hi Guys,

    Can somebody help with the above mentioned problems.....
  3. puchoo

    puchoo Regolare

    Messages:
    271
    Delhi / Shimla
    I think you have posted this in the completely wrong thread and hence lack of answers , might want to delete this and shift it to a more relevant one.
  4. Ravi

    Ravi Staff Member Janitor

    Messages:
    6,001
    Bangalore
    Grande Punto 1.3
    Suggest you to check with FASC, some electrical wiring connection might have gone loose.
    Whatever you did is correct initial things to do, but since this is not resolving issue, going to service center is only option.

Share This Page