1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

Need advise on Horn Issue in T-Jet Plus

Discussion in 'Electrical Systems' started by jitu2509, Jan 14, 2013.

  1. jitu2509

    jitu2509 Timido

    Messages:
    17
    Mumbai
    Hi Guys

    I am owning T-Jet plus which is 2 yrs old and I am facing very strange problem with related to Horn of Car.

    When I start the Car anytime in the day and when car is ideal (means engine started but not moving) at that time if I blow the horn then it blows normal (means like twin horn).

    but when i starts moving the car and push the accelerator and then press the horn at that time it blows like a single horn, again when i reduce my speed then the horn blows like twin horn.

    So help me making understand this problem and the seriousness of this problem.
  2. dj.nish

    dj.nish Superiore

    Messages:
    543
    Mumbai
    Most likely a blown fuse/relay issue. It may also be that water is seeping in causing this. I faced something similar in my Getz. Minor thing I guess, get it checked and rectified.
  3. VahanPujari

    VahanPujari Staff Member Janitor

    Messages:
    2,303
    Mumbai
    ^^
    Or may be some loose connection somewhere disabling one horn randomly. I had this issue which used to come randomly. Tighetning connections solved the issue.
  4. jitu2509

    jitu2509 Timido

    Messages:
    17
    Mumbai
    Thanks for the reply guys but as per my observation its starts when i race the car and comes to normal when car is ideal for some time, i repeatedly observed the same while my last drive.

Share This Page