1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

My Italian White Stallion

Discussion in 'Punto 1.3 MJD 90 HP' started by zenwalker, Jul 4, 2013.

  1. zenwalker

    zenwalker Esperto

    Messages:
    2,150
    Bangalore
    hmm...let me see, in a week or two the part should be in their stocks. Ill write back.

    Thanks
  2. pdydeva

    pdydeva Regolare

    Messages:
    442
    India
    Even I face the issue often. But, If I roll the vehicle a little to the front and then engage the reverse gear it locks without noise. Always wondered why the Bus and truck drivers roll the vehicle forward once before engaging reverse, now it's clear. But I understand it's bad to compare these high tech Fiat transmissions with buses and trucks.
    Last edited: Jun 21, 2014
  3. govindankvs

    govindankvs Novizio

    Messages:
    26
    US
    US
    Grande Punto 1.3
    Even I tought this 'krrr' be an issue with car/parts. Its more to do with us not going thru the manual :) Press Clutch 2secs(count 1.. 2.. engage reverse). Works like a charm. No krrr anymore.. Clearly given in the Owners Manual.
  4. zenwalker

    zenwalker Esperto

    Messages:
    2,150
    Bangalore
    In my case, taking forward then engaging reverse or just engaging on stand still results in krrr... Perhaps its due to the less lag between clutch press and gear engaging. However, some times gear does not fall in reverse slot properly. Hopefully as the SA claimed, changing in the parts would atleast solve in getting engaged correctly.

    - - - Merged Post - - -

    On a side note, today morning i checked the engine oil level stick and it was black, i was hoping it would show a clear state since the engine oil has been changed just 2 days back due to service. I am wondering if the oil was really changed or not. Any body clarify?
  5. vj_v1

    vj_v1 Superiore

    Messages:
    933
    Hyderabad
    Again. Engine oil in a diesel engine turns black almost immediately.

    To avoid the same doubt's I actually stay at the Sc when my car is getting serviced. Few hours wasted but peace of mind.

    Sent from my Moto X using Tapatalk.
  6. pdydeva

    pdydeva Regolare

    Messages:
    442
    India
    I think I didn't put it across clearly. At times, reverse gear may not slot in easily with simple pull and if you push hard it may slot with a krrr noise. To avoid this, I generally move a little on 1st gear and then bring the vehicle to a stop completely before switching to reverse gear. If you attempt to shift reverse gear while in movement, the krrr noise may be there. Anyway, let us wait and see if the SA suggested changes solve your problem.

    Regarding the engine oil, being diesel engine, even a fresh oil would turn immediately black when poured inside due to the already present carbon deposit. You can do a simple test from the dipstick oil by rubbing it between your fingers. If they are not thick with powdery substances, you are good.
  7. zenwalker

    zenwalker Esperto

    Messages:
    2,150
    Bangalore
    Dear Folks,

    Updating after along time...

    This time it was a 3 day trip i had recently (Independence day weekend). The route was BLR -> Madurai -> Rameshwaram -> Kanyakumari -> Trivendrum -> BLR.

    The roads were excellent except the Nagarcoil -> Trivendrum highway, which was not only narrow but really crazy drivers driving like maniac. It was scary enough for me.

    So total distance covered was 1800Kms and only 1 driver i.e Me :p The driving pleasure was really awesome and as always the punto really did well all over the journey. No issues at all (touchwood). Even after driving extensively for 33Hours, i did not feel much of the strain at all.

    The image depicts a max mileage i could achieve at one point of the journey, but over all FE was 22.
    10300639_311071449064527_2637664435170445962_n.jpg 10541405_673024809433785_3577103674465643098_o.jpg
    10541065_311692735669065_78748533589855821_o.jpg DSC04976.JPG DSC05007.JPG DSC04971.JPG IMG_20140815_111643.jpg IMG_20140816_070446.jpg IMG_20140816_180637.jpg PANO_20140817_133915.jpg
  8. zenwalker

    zenwalker Esperto

    Messages:
    2,150
    Bangalore
    After a 3 day long drive reported here http://teamfiat.com/threads/through-the-misty-turns-green-forest-until-the-coastline.13220/ I finally got sometime to do the wheel alignment and balancing as 15k odo is achieved.

    So today I went to madhus, A1 to get it done. But unfortunately they both were closed coz of festive.
    Then I went to vijai, JP Hagar, but I was told that their workers are not in so its gonna he a big wait. Then I visited iyengars @dvg petrol bunk.

    Here is my take on this shop agter the work done as compared to madhus from my 5k alignment time.
    1. This shop is small and not clean as compared to madhus.
    2. It lacks professionalism w.r.t work attitude as compared to Madhus.
    3. The workers here are lathargic in nature.
    4. The instruments seems to he a bit old and was giving of errors, so balancing was done more than once /tyre.
    5. They do not know or not heard of road force balancing and they were giving blank stare when I inquired but then I guessed it something to do with michellin technologies on which madhus operate with.
    6. In front of customer the workers were behaving rude, casual and even arguing with the in-charge. IMO that's not a good professional attitude.
    7. The cost is more compared to madhus for same work. Costed me 900 than 720 from madhus.
    8. The report card given to me contained more details in case of madhus than this one.
    9. At madhus the technician voluntarily did explained in detailed about the stuffs being done with handing over to me a brochure. Here there is no such people at all.
    10. At madhus they used the machine to mark or decide the tyre rotation numbering but here the two workers were confused at first and did some jugaad theory to rotate and they didn't even mark the tyre for rotation purposes like at madhus.
    My take: I still prefer madhus for the job as the proffesionalism shown w.r.t work was really good and gives me confident.
    Last edited: Oct 24, 2014
  9. zenwalker

    zenwalker Esperto

    Messages:
    2,150
    Bangalore
    Today at vecto, odo stands 16.5k. Had problems with front suspension acting weird. After opening up it was rectified that both struts have gone very hard. Hence both got replaced.
    Have requested to check for engine mounting issue due to a slight vibrations during ignition or off. Still going on.
    meanwhile..
    IMG_20141119_111311.jpg
    --- Double Post Merged, Nov 19, 2014, Original Post Date: Nov 19, 2014 ---
    Update:
    C mount aka link rod rubber crack. Replaced. All under warranty.

    Given my usage on highways most of the time, the break pads shall survive for next 5k. Surprised.
    IMG_20141119_114359.jpg IMG_20141119_114337.jpg
    IMG_20141119_114359.jpg IMG_20141119_114359.jpg IMG_20141119_114337.jpg
    punto_emotion likes this.
  10. ghodlur

    ghodlur Esperto

    Messages:
    2,326
    Thane
    Even I have observed the same in my Punto too. Is it common for the car? Whats the diagnosis for the issue? Mounting bolts loose or gone bad?

Share This Page