1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

My grande Punto 90HP - Stunning Italian Beauty "Paula"

Discussion in 'Punto 1.3 MJD 90 HP' started by imranshks, Mar 17, 2013.

  1. Nadeem Ahmed VR 46

    Nadeem Ahmed VR 46 Esperto

    Messages:
    1,123
    Gadag
    Sorry Krishna i mean to say they were not ready to diagnose the actual issues & instead used to blame Fiat.
  2. imranshks

    imranshks Superiore

    Messages:
    510
    Bangalore
    A new issue popped up in my car after clutch replacement !! The speedometer shows 40 kmph while the GPS speed shows 65 kmph... Rest of the components of odometer like fuel gauge and rpm are working fine, just the speedometer is malfunctioning.

    As stated by @DRIV3R the gearbox was removed during clutch replacement and in the process the speed sensor might have been damaged.

    Hoping to get this fixed sometime soon as Vecto motors has already acknowledged the issue yesterday.

    After 16,500 kms, now my car seems to be brand new with butter soft clutch and a fully functional turbocharger.

    Cheers :)

    Sent from my Lenovo P780_ROW using Tapatalk
  3. vayfiat

    vayfiat Amatore

    Messages:
    220
    Bangalore
    Hi Imran,

    Even I have this issue I think. Nowadays it has become too frequent. Sometimes, the reverse gear simply doesn't get engaged. If I try again, it will give grinding noise. If I release the clutch pedal fully and try again, it will get engaged. I'm not sure if you too had faced the same issue. I don't think I'm doing anything wrong. I never changed gears in half clutch.

    Regards,
    Vinod.
  4. imranshks

    imranshks Superiore

    Messages:
    510
    Bangalore
    In my case even the process you stated above was not working to engage reverse gear. I used to face issues in changing the gears when engine was hot. On cold engine it used to be normal. The most troublesome part was reverse gear :(

    Clutch seems to be the culprit in your case too !!!

    Sent from my Lenovo P780_ROW using Tapatalk
  5. vayfiat

    vayfiat Amatore

    Messages:
    220
    Bangalore
    Yes, even in my case, the issue happens when engine gets hot. Nowadays there is another issue when changing to 5th gear - after disengaging from 4th, it will be stuck like a rock. I will apply the same logic I do for rev gear, it will work then. :(

Share This Page