1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

My grande Punto 90HP - Stunning Italian Beauty "Paula"

Discussion in 'Punto 1.3 MJD 90 HP' started by imranshks, Mar 17, 2013.

  1. pdydeva

    pdydeva Regolare

    Messages:
    442
    India
    Guess it's something due to the recent dog hit. I think you should ask the FASS guys to get the inter-cooler checked.
  2. imranshks

    imranshks Superiore

    Messages:
    510
    Bangalore
    Yes, I too suspect it to be the cause. If the scanner cannot give out the details, visual inspection of all the components is the only way out.

    Sent from my Lenovo P780_ROW using Tapatalk
  3. nkrishnap

    nkrishnap Staff Member Janitor

    Messages:
    1,900
    Bangalore
    Bangalore
    Linea 1.3
    I believe you already had the visual inspection done to identify any damages after the dog incident. Is this problem from very recent days or an existing one which needed attention.
  4. imranshks

    imranshks Superiore

    Messages:
    510
    Bangalore
    Yes, last time we met when the inspection was done. The issue has not been resolved yet. I thought after service, the car will come back to normal but there's no difference even now.

    Let's see what the technician has to say today.

    Sent from my Lenovo P780_ROW using Tapatalk
  5. imranshks

    imranshks Superiore

    Messages:
    510
    Bangalore
    Update: had been to Vecto motors today to get the vehicle checked. It turns out to be that Vacuum tank has developed cracks due to which they suspected a leak resulting in low pick up.
    SC has placed an order for new vacuum tank, once it is replaced the issue must be resolved.

    Even after the vacuum tank replacement if the issue persists, a detailed diagnosis of turbo charger (EGR Valves) etc shall be carried out it seems.

    Overall, a satisfying experience !!! Shall keep you guys posted.

    Cheers.

    Sent from my Lenovo P780_ROW using Tapatalk
  6. shams

    shams Esperto

    Messages:
    2,388
    Bangalore
    hope they have already checked all the turbo hose pipes
  7. imranshks

    imranshks Superiore

    Messages:
    510
    Bangalore
    Yeah Shams, they said they have checked it today and found that vacuum tank to be the culprit. They say its a small component made up of plastic, the pipe that connects the vacuum tank and the turbo is cracked.

    Let's see after the replacement is done.

    Sent from my Lenovo P780_ROW using Tapatalk
  8. DRIV3R

    DRIV3R Esperto

    Imran bhai, so just as we suspected it is the Vacuum tank! That is the prime suspect in the VGTs when you don't feel the turbo kick.

    Hoping that it would be solved soon.:redcar
    1 person likes this.
  9. imranshks

    imranshks Superiore

    Messages:
    510
    Bangalore
    Yes, you got it spot on bro. Now they have glued it using something but its just a temporary fix.
    It will take at least a week for the spare to arrive. Let's see the result after replacement. :)

    Sent from my Lenovo P780_ROW using Tapatalk
  10. imranshks

    imranshks Superiore

    Messages:
    510
    Bangalore
    Had been to Vecto motors this evening. The vacuum tank ordered had arrived and was due replacement.

    The old vacuum tank's connecting pipe was broken and hence the turbo kick was missing.

    On my way to Vecto the car was literally struggling to overtake a BMTC bus on Hosur road.

    Finally the Vacuum tank was replaced and the vehicle was handed over to me in no time (roughly 20 mins)

    Drove back home, and the vehicle is back to normal, revv friendly and no power lag !!!

    A big thank you to Channabasappa for helping me out in nailing this issue and also a big thank you to Secret Santa (sorry I can't disclose who it is, but I am sure he will read this post).

    Cheers :)

    Sent from my Lenovo P780_ROW using Tapatalk
    4 people like this.

Share This Page