1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

My first car and im feeling a little low - Power issues

Discussion in 'Technical' started by Tootronix, Jan 26, 2016.

  1. Tootronix

    Tootronix Timido

    Messages:
    13
    Bangalore
    Bangalore
    Grande Punto 1.3 90 HP
    Cool done. Will do that :) thanks bro
  2. shivraj5624

    shivraj5624 Amatore

    Messages:
    120
    Belgaum, Karnataka
    belgaum
    Linea 1.3
    Mine is 2012 Jan model.. I am the only guy here with the problem sales manager also said that he has discussed the same problem with fiat India. They said . any minute foreign particle in fuel tank can also cause this problem. So, after every time we rest at the engine , the car is back to normal. Because the motor supplying the fuel from tank to the front side also goes off and on along with the engine.so there is a temporary relief always..in my case , the problem always props up when I fill diesel from a non reputed bunk.How old is your car ??
  3. Tootronix

    Tootronix Timido

    Messages:
    13
    Bangalore
    Bangalore
    Grande Punto 1.3 90 HP
    @shivraj5624 thanks much I'll note that. I'm at the service centre now and was getting the car checked..that problem had not popped up for awhile but still wanted it checked..I did mention to the service agent here to have the EGR checked and he said he would and also in one other post here on TF one had mentioned that their turbo hose was bent and was causing a choke..I did tell him that and he checked the possible hoses ..and well he did notice the intercooler hose to be a little bulged and more like jammed here are a couple of pics..I hope this is the only issue ...fingers crossed..will let ulyou all know how she performs after I get her back..

    IMG_20160204_103208.jpg

    IMG_20160204_103244.jpg
    Naughty and Murphy_Fiat like this.
  4. Murphy_Fiat

    Murphy_Fiat Superiore

    Messages:
    648
    Trivandrum
    Trivandrum
    Linea T-Jet
    Hope this will solve your issue completely,
  5. Tootronix

    Tootronix Timido

    Messages:
    13
    Bangalore
    Bangalore
    Grande Punto 1.3 90 HP
    Murphy_Fiat likes this.
  6. Tootronix

    Tootronix Timido

    Messages:
    13
    Bangalore
    Bangalore
    Grande Punto 1.3 90 HP
    Hi Team I’m back again J



    Ok my car has not come up with the problem and it’s been a while now. I don’t know if it was the cleaning of the EGR Valve, changing of the intercooler hose or changing a few things in the way I drive.



    1) Well a little about me, I’m a person who owns a 2 stroke bike (Yamaha RXZ) and thus engine breaking has been in my blood since, and more so learnt driving on a bolero (My brothers) who too has an RX 135. So it had come down to us while driving, a tendency to engine break while simultaneously using the break peddle too and this we did for more than 6 years on the bolero and few petrol cars that our friends owned. And was done every single time when we had to break (back then it felt like ABS to us). So this is something I stopped doing, these few days on my girl (I mean the 90hp ok!).



    2) on a post here one had mentioned to let your car idle for about 30secs during the first start of the day before moving. (I had been doing so but I guess for about 15 seconds) I now leave it to idle for about a minute now And more I do not open the car until I have driven at least 4 – 5 Kms.



    3) Well the bikes we own and the prior car (Bolero) should have given you a hint the we love a little bit of off-roading , and yes I’m into it a lot but on my bike. So thus we went over rebel without a second thought, this is one of the reasons I picked a Punto ( I mean just one off the 100 reasons) Her ground clearance!!!. Ok not that I go off-roading on my Punto but used to take her over humps a little easier as I did not get the feeling of lifting me derriere like I did on my friends Polo, every time we went over a hump. I have stopped that too by literally taking her over ever hump the slowest possible way. Well this is because one had mentioned that the sediments or particles present in the fuel could be a cause to create blockages and thus wanted these sediments to stay put where ever they are and not disturb them or they would enter and clog one of my filters.



    Ok so these are the updates as of now. Let’s see how it goes for a while and slowly will start all of these practices again, one at a time, to rule them off should the problem not occur.



    P.S I’m not much of a writer so please excuse me in the way I’ve put thing across in this post. It may be confusing and if it is, please revert and ill clarify J (and i keep using "one had mentioned" and not the persons name cause i dunno where to find the post. Will get used to navigating here and will mention names. but thanks all for your support)



    Happy torquing to you all again!!



    Toosa
    Naughty and Murphy_Fiat like this.
  7. Murphy_Fiat

    Murphy_Fiat Superiore

    Messages:
    648
    Trivandrum
    Trivandrum
    Linea T-Jet
    Did they Rectify the issue with your Car.
  8. Tootronix

    Tootronix Timido

    Messages:
    13
    Bangalore
    Bangalore
    Grande Punto 1.3 90 HP
    Hi Team,

    Im back again. After almost driving 2000 kms the problem has not sprung up, and the moves like the breeze now. After my last service I did notice that they had rebooted the ECU, I suggest all you facing the same problem to give it a shot. Hopefully that does resolve your problem.

    Happy Torquing!!

    Cheers!!
    Toosa

Share This Page