1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

Multiple Race-chipped Jets

Discussion in 'Linea 1.3 MJD' started by jishnu, May 18, 2011.

  1. kr_vasudev

    kr_vasudev Superiore

    Messages:
    611
    Bangalore

    Is this applicable only to your car ? I recall my car also underwent similar change during 2011. My car pulls towards right these days :(
    Last edited: Dec 29, 2013
  2. jishnu

    jishnu Superiore

    Messages:
    651
    Bangalore
    Yes Sir, only for my vehicle as I have been fighting with this from 2 years now.. hehe!
  3. jishnu

    jishnu Superiore

    Messages:
    651
    Bangalore
    Update: Fiat changed the axles (Front and Rear) and the problem seems to persist. The Only thing now I can think of is a manufacturing defect. The Chassis of the car is defective and maybe I will ask Fiat for a Replacement irrespective of the kms done as I had paid the full amount to them and they did deliver me a Defective product.
  4. Pradeepms

    Pradeepms Amatore

    Messages:
    172
    Mysore, Karanataka
    Mysore
    Grande Punto 1.3
    hey guys, my car is also pulls towards right and I have checked the allignment. balancing and wheel rotation :(
    Also whenever I go over the humps there is some sound (karaak..) and this FIAT guys are not able to solve from last 8 months.
    They told they have changed the shocks and still that sound is coming.... anyone knows abt this....
  5. jishnu

    jishnu Superiore

    Messages:
    651
    Bangalore
    Car has done 105000kms as of now and counting. Everything is fine apart from the left pulling issue. Fiat hasn't been able to solve it till date lol
  6. punto11

    punto11 Amatore

    Messages:
    70
    assam
    you can try disassembling front struts lubing greasing and fitting exactly with same torque in the top mounting. My car had this issue and got solved with this.
  7. moksh

    moksh Regolare

    Messages:
    351
    Mumbai/Germany
    Linea 1.3
    @jishnu Can you update your race chip settings.
  8. jishnu

    jishnu Superiore

    Messages:
    651
    Bangalore
    Thank you for the suggestion mate. Fiat had already changed the suspension once to see if that was the reason. Everything has been checked thoroughly but the issue persists.

    Now its at L= 3 , R=1.

    Hope this helps.
  9. moksh

    moksh Regolare

    Messages:
    351
    Mumbai/Germany
    Linea 1.3
    I am still reading your 23 page thread Till now found E-3 and E-4 to be the best
  10. pradeepsangwan

    pradeepsangwan Amatore

    Messages:
    87
    Bhiwani, Gurgaon
    Gurgaon
    Grande Punto 1.3
    @jishnu can u post a video for 0-100 run

Share This Page