1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

Minor Issues - Squeaks, Rattles and niggles

Discussion in 'Technical' started by cliffhanger, Jun 3, 2010.

  1. sathishgv

    sathishgv Regolare

    Messages:
    496
    Paradip, odisha
    Grande Punto 1.3 90 HP
    Is this sound coming when you are at the end of travel of clutch, while releasing it in first gear? because lately me too having the same problem. This sound comes only when the car is moved from stand still, in first gear. Also when the clutch is kept half pressed when the car starts to move and then release fully after the car moves, this sound cannot be heard. Will it be an issue with the clutch? I have clocked almost 67K+ and my car is now >5 yrs old. Anyway planning to take it the service center as my regular check up is pending too. will post an update on the problem.
  2. naruf1

    naruf1 Amatore

    Messages:
    170
    Namma Bengaluru
    I had similar issue in my drive, It could possibly be due to loose tie rod. Please visit asc and ask them to check the same.
  3. vista7155

    vista7155 Regolare

    Messages:
    313
    bangalore
    @sathishgv
    it is not related to clutch because i have observed this while stopping the car but anyhow we can hear when it starts moving slowly and disappears once the speed is crossed 10kmph I.e, when we are around 5kmph we can hear the noise.
  4. sathishgv

    sathishgv Regolare

    Messages:
    496
    Paradip, odisha
    Grande Punto 1.3 90 HP
    @vista7155, if its not a clutch issue then its a great relief for now but let's wait till Friday when I am planning to go to the SC.

    With the issue being with the tie rod, then the sound will come during running also. I have experienced this issue and have solved it too. This sound which we are discussing about is only during moving the car from standstill only. After the car moves this kind of sound does not come.
  5. vista7155

    vista7155 Regolare

    Messages:
    313
    bangalore
    ^^ You are absolutely right.
    i have also booked Service for tomorrow and let you know what was the root cause.
    I have one more issue where i can hear rattling in the dashboard inside the instrument cluster and it will be heard in certain rpm.
    The rattling sound is like some screw have been loose.
  6. N Kiran

    N Kiran Staff Member Janitor

    Messages:
    1,518
    Hyderabad
    @vista7155 : I had previously in my Punto the same Krr noise during low speeds. Issue was resolved by cleaning the rear brake liners. Try getting them cleaned.
    PradeepM likes this.
  7. vista7155

    vista7155 Regolare

    Messages:
    313
    bangalore
    Kiran thanks for the advice.
    Today I received back from service and the initial krr sound is resolved,the source was engine mounts which has rubbers for holding the engine.
    The ASS has replaced and let me check for some kms if it is resolved completely or not.
    N Kiran and PradeepM like this.
  8. N Kiran

    N Kiran Staff Member Janitor

    Messages:
    1,518
    Hyderabad
    @vista7155 :Hope they were replaced under warranty.
    PradeepM likes this.
  9. vista7155

    vista7155 Regolare

    Messages:
    313
    bangalore
    Yes it was replaced under warranty.
    For dashboard rattling they charged 1486.
    Earlier the bill was 6000.
    After so many negotiations it came down to 1.5k.
  10. mhitesh

    mhitesh Amatore

    Messages:
    158
    Airoli, Navi Mumbai
    Airoli, Navi Mumbai
    Grande Punto 1.4
    I am not sure If I should start a new thread hence, posting here.

    I have a strange issue with my Punto, I have taken it to RS Motors a couple of times however the issue seems to creep up again.

    Whenever I have my handled fully locked towards the left hand side while turning I can hear a screeching noise. This only happens when the steering is fully turned towards the left hand side. The noise appears to be coming from the right front side. I initially took my Punto to RS Motors where they said that it might be an issue with the motor connected to the steering wheel and I should get my car back after a few days as they don't have a spare motor to test, however they also added that the possibility of the motor going bad is negligible.

    When I wen't back after a few days they said it seems to be an issue with the belt connecting the motor and they replaced the belt and the issue got resolved for a week or so, however again I find the issue issue creeping again and the noise seems to have increased.

    Please let me know if anyone faced this issue and what was done to resolve it.

Share This Page