1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

Minor Issues - Others

Discussion in 'Technical' started by gururajanv, Jun 2, 2010.

  1. abk1980

    abk1980 Amatore

    lol :D
    The question is did it manage to make it across!! :p
  2. vj_v1

    vj_v1 Superiore

  3. sungoa2010


    I still wonder how people managing in Fabia which has a GC of 158. When I test driven it I didn't find it too much problematic.
  4. gp_prakash


    1yr/15000KMS 2nd service issues

    I was surprised when my Service adviser called to inform that brake pads needed to be replaced on my 12300kms run 1.3MJD Punto. I did some searching around and it did not seem right. I asked him to hold off from replacing it for now. When I collected the car, they had replaced the diesel filter.

    In 2/3 days there was a light on the panel and also MID showed "Check Diesel filter". Also in the meantime - I started paying closer attention to when I was braking. There was a "grrr, grr" noise everytime I braked. The thing is, it may been there earlier as well but I had never noticed it, also its more noticeable when there is lesser traffic around.

    Took it back to the service centre and reported both the issues. Of course they changed the brake pads, the good thing was that I was able to see them remove it and put in the new one. The old one was really worn out - probably had only 1mm remaining. Another 200-300 kms with that and there would have been metal on metal contact which would wear out the discs. Not sure whether its my driving style (which is not hard by any means) or bangalore traffic thats wearing it out so quickly. They also removed and reattached the diesel filter and I don't see the warning on the MID anymore.

    All in all - a costly 2nd service (~9.5K) but since its annual and the car gives so much driving pleasure, I guess its something I can live with. My question - will they change the diesel filter at every service?
  5. Deisel filer is changed every 15K kms, i had the smae issue of breke pads wearing out 12-13K kms but since it was changed i have done 17 K Kms still 4 mm left on the pad.
    It's the subtle adjest ments you can make to get better life out of breke pads.
  6. Bala

    Bala Esperto

    The car was taken to the TASS,was diagnosed with rats damaging the A/C pipe,repair was done but still,even after several months the odour has not gone,it is as much there as was before.(should be the smell of rat urine!)
    Rats had damaged the combination switch too,was not available anywhere in Chennai,every TASS informed us that it will take 20 days to procure,we waited,no one had even placed order,contacted MANAKULAR MOTORS,Puduchery.They placed order immedeiately and was fitted in 3 days.So,Chennai guys,having a difficult time with Chennai Tass can come to Puducherry,it would become a two in one purpose trip!!(Rats have eaten up everything inside glove box,all the plastics around bonnet area,there were 3 kid rats too in the driver foot well,I was about to leave them outside in a dustbin,when my Dad prevented me saying that the mother would come looking for the rat kids,so leave it near the car!)
    Now,how to get rid off the foul smell??
  7. vijays777

    vijays777 Regolare

    Linea T-Jet
    what type of Floor Mats do you use ??
    If its water absorbed and not dried also you will get worst smell.Due to Recent rains it wud have been wet on bottom . On top it will be looking fine ..

    FYI, If its FIAT mat then its the reason . Bcoz i faced this
    Last edited: Jan 8, 2012
  8. Bala

    Bala Esperto

    Yes Vijay,you should be correct.Even I was thinking that the kid rats would have passed urine in the floor carpet/mat and that would be the reason for the foul smell,I shall wash and dry it and see.
    I use both the 700Rs fabric mats and the rubber kind of mats provided by Fiat for free.
  9. arunk


    Problem with A/C on Punto E.Pk

    Hi All,

    All of sudden for the last two days the AC doesn't seems to working fine. It's just blowing the AIR and doesn't seems to be getting chilled even after say 15-20 mins of running. Any idea what could be the reason.

    Mine is 5 months old and ran almost 4k kms so far. I have observed the AC performance for the last month or so has not been like earlier and all of sudden it is completely not getting chilled now. Anything to do with the coolant? Any thoughts please?

    Arun K
  10. teky

    teky Esperto

    Check the O Rings. Can be a faulty one.

    Sent from my LT15i using Tapatalk

Share This Page