1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

Minor Issues - Others

Discussion in 'Technical' started by gururajanv, Jun 2, 2010.

  1. suniljm

    suniljm

    Messages:
    11
    Hyderabad
    Thanks sumit. That sound wasn't there during the first 150KMs and started only today while returing home. Is link rod issue a major one? Any part to be replaced? i am worried now as SC may take weeks to order and get the part.

    I didn't do exhaustive PDI. Just checked, tyres, odo, Blue & Me, engine etc.

    -suniljm
  2. Tarun

    Tarun Amatore

    Messages:
    227
    Bhiwani, Delhi
    worry not fellow Punter ... this will Vanish, as time passes by..
    i too had this "khat khata khat" not only me but my 3 punto frnds also had this sound .. but vanished at my 1st 3K free service .. it;s link road issue..
    no need to panic ...
  3. suniljm

    suniljm

    Messages:
    11
    Hyderabad
    but tarun..my Punto (all new Puntos) 1st service will be at 5K which will take around 4 months for me. Do you suggest me to take it SC and get it fixed now?
  4. PaddleShifter

    PaddleShifter Staff Member Janitor

    Messages:
    2,697
    Chandigarh
    Grande Punto 1.3
    Suniljm, regarding parking lights of only one side being turned on, it is a feature. Check this. After you remove the key, turn on the parking lights. Both side lights will turn on. After that, turn the indicator stalk to right or left turn position. You will notice that only the lights of that side will be on. Amazing feature.
  5. RAAM

    RAAM

    Messages:
    24
    Navi Mumbai
    Thanks Chaos, will try this and update. I also had an initial thought this could be due to some ECU error.

    Bhai, in the picture attached in my original post, I had boxed the relevant area in the panel in red, however I did mention that the warning light is glowing very midly and indeed it lights up in yellow colour.

    vks, will try this and if the issue still persists will checkout with TASC, I plan to go to Fortune Nerul, which is the closest one known to mw. If any of the Navi Mumbai TFI ians know any other better place, please let me know.

    One more error appeared in the MID, the warning light for the external lighting failure starts to come up intermittently the in MID comes a message to check 'Number Plate Lights'. However when I checked the number plate area while the error was on, the number plate lights were working fine. I am suspecting that the ECU error codes have gone for a toss and needs to be reset, experts your thoughts please.
    Last edited: Aug 7, 2011
  6. suniljm

    suniljm

    Messages:
    11
    Hyderabad
    I will be taking my car to Malik Cars tomorrow for the link rod issue..sad to take the car to service center with in 3-4 days of taking delivery. Anyway, any Hyderabad guys in the forum help me with their contacts in Malik Cars service.

    Also, Is it only some tightening issue or link rod to be replaced. If it is to be replaced availability could be an issue.

    -suniljm
    Last edited: Aug 7, 2011
  7. Tarun

    Tarun Amatore

    Messages:
    227
    Bhiwani, Delhi
    @ SUniljim
    bro i started having that sounds arnd 1200Kms.. visited the showroom, they checked everything & reported tat everything is OK nd i don't need to worry about it but they were not able to resolve my problem, cuz they takes a test ride to study the problem, but the thing was whenever i got my car test driven, my car never makes sound .. LOL
    it was spontaneous nd emerges at his own will .. then after talking to sum frnds and sum FIat geeks i decided to ignore it .. and after my 3 K service, it vanished permanently .. or i can say it vanished by itself arnd 2800 Kms..
    well my guess is that parts settles up here and there .. and @ 2800 everything was fine on it's own or done on service schedule ..
    i'll just suggest you not to worry about anything ... don't think tat your suspension will worn out or you'll see your own tyre rolling on the road :p
  8. suniljm

    suniljm

    Messages:
    11
    Hyderabad
    In my car the khat khat sound is coming continuously unless the road super flat like glass. In other words it is making the noise 80% of the time even on best of the roads. Only 175KMs done and 4 days old vehicle:A
  9. Tarun

    Tarun Amatore

    Messages:
    227
    Bhiwani, Delhi
    i'll say drive a lil more .. arnd 1000 Kms .. and see if it still exists ...
  10. nobrakes

    nobrakes

    Messages:
    137
    Mumbai
    Hey Suniljm, if u thought u had it bad then listen to this......my car started making that "Khat Khat" sound on the day of delivery, infact as soon as i drove out of the dealership!!

    Took it to the workshop the next day, where they changed the link rod and I was out of there in 30 minutes. The service advisor said it seems like a particular batch of punto's suffer from this problem. My 1.2 Emotion is of May 2011 make.

    I think you should get it changed ASAP.

    Cheers.

Share This Page