1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

Minor Issues - Others

Discussion in 'Technical' started by gururajanv, Jun 2, 2010.

  1. kedarbendre

    kedarbendre Esperto

    Messages:
    4,215
    MH 12
    Re: What to do with Brand new car......

    Hay thank you so much guys. Amogh let's meet someday. On this weekend I am going to take delivery.
  2. NAREN64

    NAREN64

    Messages:
    285
    COIMBATORE
    Re: What to do with Brand new car......

    Hai kedarbendre,

    Before your new alloted car goes for registration make a Pre Delivery Inspection. Some tips for PDI are in the following Post.

    viewtopic.php?f=61&t=255
  3. obliex

    obliex Amatore

    Messages:
    146
    Pune
    Re: What to do with Brand new car......

    Most important for MJD , do not switch off the engine immediately after you have parked . Why ?? the reason is turbo which is still hot after a drive and needs oil for lubrication. Allow about 30secs for the things to stabilize and then switch off the engine. The manual will also recommend the same
  4. infernal

    infernal

    Messages:
    51
    Gurgaon
    First Start

    Hi,

    When I start my car for the first time, i.e. when the engine is cold, my car performs much better than it does when the optimum temperature is reached. On the first start the engine revvs more freely, the engine noise is also significantly low and the car drives much faster.

    Anyone else noticed the same, anyone knows the reason for the same?

    Thanks
    Anshul
  5. vIjAy_kHaSa

    vIjAy_kHaSa Esperto

    Messages:
    1,353
    Panchkula
    Re: First Start

    Strange its opposite for me.
    In cold start my car is noisy but smooth but gets quiet and even more smoother after warming up
  6. infernal

    infernal

    Messages:
    51
    Gurgaon
    Re: First Start

    Yup, thats how its supposed to be...the car is supposed to get quiter when its warm. Strange that it works the opposite for me..
  7. vIjAy_kHaSa

    vIjAy_kHaSa Esperto

    Messages:
    1,353
    Panchkula
    Re: First Start

    Have you tried resetting the ECU
    Remove the -ve terminal from battery for about 5 mins and then put it back and then drive for about 10 kms and see if any change happens
  8. amogh

    amogh Staff Member Janitor

    Messages:
    1,377
    Pune
    Grande Punto 1.3
    Re: First Start

    Wow !! This is reverse !! In fact I HATE driving the car when it is cold. Just does not feel good.

    I agree with Vijay : reset the ECU

    Amogh
  9. Chaos

    Chaos Regolare

    Re: First Start

    Anshul, aren't you using a different company's synthetic engine oil???
    OWS Turboracing??

    it may be because of that.... ::V
  10. infernal

    infernal

    Messages:
    51
    Gurgaon
    Re: First Start

    Yup i'm using OWS Turboracing, don't see how its related though.
    And this "thing" existed before the oil change too.

    Can it be because of pete's box?

Share This Page