1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

Minor Issues - Engine

Discussion in 'Engine Compartment' started by ysapre, Jul 8, 2010.

  1. GP_Freak

    GP_Freak Amatore

    Messages:
    240
    Chennai/Madurai
    Chennai
    Linea 1.3
    Gosh, I have never noticed it so close about the bonnet heating. I will check and update once my ride is back from the service centre.
  2. bibhupanda1

    bibhupanda1 Timido

    Messages:
    6
    Pune
    Pune
    Linea 1.3
    Bonnet Heating is due to Hot coolant collection in Tank (Small white tank). in MJD, it is on the right side of bonnet (Left, if you face the engine / radiator). This is pretty normal.
  3. rainy

    rainy Amatore

    Messages:
    57
    Bangalore
    I've got my 60K service done. Both before and after this, I notice that whenever I start the car, there is a deeper noise than normal, especially, when I race the engine. I mentioned this during to the service engineer, but predictably, that sound was absent during the entire time the car was at service. Can I run some steps to narrow down the noise?
  4. gauravp

    gauravp Amatore

    Messages:
    86
    Pune
    Hi All,

    Need your suggestion on the issue with my engine oil indicator at the MID for my Linea Tjet+. Today morning, while coming to office suddenly the engine stopped and message saying "Insufficient Oil Pressure" started glowing. I tried to start engine again but it did not worked. After 5 minutes, I again tried and engine started and the message also not appeared. Luckily I was inside my office campus, so parked the car immediately in the parking and checked the oil level. There was some oil marking at the oil stick but not sure if it was at correct level. Now I am afraid if the same will happen again in the evening while going home. Could you please suggest what could be the possible issue? Shall I go to service center sometime during the day and get it checked or shall I take risk to go home directly and get it checked tomorrow morning? please help.
  5. bibin

    bibin Regolare

    Messages:
    297
    kochi
    get in touch with FASS asap. i will you suggest to take minimal risk in cases like this.
  6. pdydeva

    pdydeva Regolare

    Messages:
    442
    India
    See how to check the correct engine oil level from your owner's manual. It's mandatory to know. Posting you a link for help

    http://www.team-bhp.com/forum/long-...2k-kms-update-page-182-a-106.html#post2143682
  7. Anup

    Anup Regolare

    Messages:
    303
    Bangalore
    Bangalore
    Grande Punto 1.3
    @pdydeva you can search for the dipstick image on google than using the one on published on T-BHP site :p(just kidding)
    When the Engine is hot it is difficult to get the exact engine oil content, rather you pull out the Dip Stick when the engine compartment is cold and see what's the level, if the level's fine then Oil Pressure Switch or the Oil Pump is (or) are the culprit for this issue.

    Strongly suggest Do Not Drive the car, have it towed to the FASS.
    punto11 likes this.
  8. gauravp

    gauravp Amatore

    Messages:
    86
    Pune
    Thanks all for your valuable inputs. I spoke with FASS SA and he suggested to drive the car to service center if the message is not coming again. I drove to SC and they checked it and found out the issue with battery. Service engineer told if the battery voltage is low then sometimes we get such messages. He checked the engine oil level and found it appropriate. My car battery is now 5 year old so he suggested to get it changed.
  9. meples

    meples Novizio

    Messages:
    47
    Bangalore
    Grande Punto 1.2
    Hello, I noticed this in the morning today. I dont really know what it is called - valve? Is it engine oil leaking? It looks fresh. Pls advice what to do.

    IMG_20160117_233751.jpg

    IMG_20160117_233900.jpg
  10. gpunto75

    gpunto75 Amatore

    Messages:
    162
    Nasik
    Grande Punto 1.3
    I have noticed a `Khud Khud' sound just after the engine stops, as if something is loose in the engine compartment.
    I hear the same sound 1 of the 10 times over large speed breakers if I'm over 10kmph speed.
    I don't hear this sound if i pass the speed breaker/pothole carefully.
    Any suggestions please.

Share This Page