1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

Minor Issues - Engine

Discussion in 'Engine Compartment' started by ysapre, Jul 8, 2010.

  1. pdydeva

    pdydeva Regolare

    Messages:
    442
    India
    Not just for Maxtor's query. In general, I do feel that there is less activity in the TFI forum overall. Is that due to the effect of Social media apps or Whatsapp groups?

    I'm not sure if I'm the only one who is feeling so, but the forum is not like what it was an year before.
    Last edited: Jun 18, 2014
    2 people like this.
  2. asimpleson

    asimpleson Esperto

    Messages:
    3,000
    Heptanesia
    Linea 1.3
    It could be either Throttle Position Sensor or Idle Air Control. OBD scan maybe necessary to find. Please post once you find the real solution.


    Maxtor, I did not open the thread in morning after reading, "thanks for all replies - close the thread". I thought you really got your answers. Please post "bump .." next time to remind or revive thread.
  3. mahesh.bandel

    mahesh.bandel Amatore

    Messages:
    240
    Pune
    Grande Punto 1.3
    Could be the TPS or the speed sensor. Have you got the car checked at FASS?

    Cheers,
    Mahesh
  4. Iyu

    Iyu Timido

    Messages:
    14
    bangalore
    Get the fuel injector system cleaned.
    Had the same issue in my earlier car, after numerous visits, my friend sorted it out for me - injectors
  5. hari.vl

    hari.vl

    Messages:
    1
    Bangalore
    Hi guys, I am new here. I've owned a Palio Stile 1.6 for 6 years now. In the last few months I've had this idling problem and it is quite irritating. Just like Maxtor explained. I've had instances where the idling went to 0 and the engine switched off. I've visited the FASS multiple times. And, the issue never went away. I got the throttle body cleaned once and it seemed to have fixed the problem. But, after a few days it showed up again. I think it could be a vacuum leak but with my limited knowledge, I cant get in there. Recently, the idling just went high and the RPM meter dropped to 0 and the battery indicator came on. And, the car refused to start. FASS says that the battery is a problem. Amaron battery service person says, its the alternator. I've really had enough back and forth and decided to sell it. But, something really is holding me back. Only if someone can help me with a solution and point me to a person who can really troubleshoot it.

    Thanks in advance
    Last edited: Jul 10, 2014
  6. asimpleson

    asimpleson Esperto

    Messages:
    3,000
    Heptanesia
    Linea 1.3
    There could be an issue with some sensor also, like perhaps the lambda sensor as in Palio GTX. You have to ensure that alternator and battery are in perfect health first. So do whatever to confirm that battery or alternator or both are in good health. There are other dealerships in Bangalore where you could get this problem solved. Selling the car for this particular issue you mentioned is highly not recommended, unless you want to go for some car upgrade.

    Best of Luck.
  7. Anup

    Anup Regolare

    Messages:
    303
    Bangalore
    Bangalore
    Grande Punto 1.3
    @hari.vl, please change the TD Sensor of the car with a new Sensor, its a black wire right next to the Engine, it's the only problematic part of the GTX engine.
    You should get this on 99rpm.com under sensor.
    You need a mecanic who can just follow the already connected sensor and do the same as guide and replace the sensor with the new one until then please do not try to crank the engine as it will drain the battery.
    This should cost about 3-4K
  8. AshithK

    AshithK Novizio

    Messages:
    32
    Bangalore
    Nope it cannot be replaced with a VGT
  9. DeLineated

    DeLineated Timido

    Messages:
    18
    MH12
    Not sure if there is really an issue, but I have noticed that the bonnet and side of the front panel imediately behind the headlights get quite hot , on both left and right sides, even after relatively short drives. The rest of the bonnet is at ambient temperature. Car in question is a Linea TJet. Opening the bonnet there is nothing in that area that suggests why it should get hot. Maybe all the hot air pumped by the radiator fan accumulates at the sides before dissipating ?

    Has anyone with a Tjet noticed the same ?
  10. Ravi

    Ravi Staff Member Janitor

    Messages:
    6,001
    Bangalore
    Grande Punto 1.3
    This bonnet heating happens in MJD too, I think, nothing specific to T-Jet.

Share This Page