1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

Minor Issues - Engine

Discussion in 'Engine Compartment' started by ysapre, Jul 8, 2010.

  1. No shams. I filled tank full diesel last sunday. The tank is half full now. The clutch pedal is shaking and making mild squeak. The car was superb today morning.
  2. shams

    shams Esperto

    Dont worry Srida, it should be some minor problem...get it rectified tomorrow and do let us know what exactly it was..
  3. Sure shams I will update the thread.
  4. Tron

    Tron Superiore

    @srida, i cant get you in 1st post sayig @2.5k Rpm cat touch 60kmph. But in which gear?? Here let me tell you ideal rpms in diff. gears, check them as per it.
    In 4th gear at 60kmph car maintain 2k Rpm.
    In 5th gear at 100kmph car maintain 2.5k Rpm.
    So get it checked if she is behaving proper or not. Get your car checked with SA neatly! Insist him for longer car trial unless you are satisfied with no. of quories you escalated to him.
    Keep us updating further progress.isfied with no. of quories you escalated to him.
    Keep us updating further progress.
    Last edited: Sep 29, 2011
  5. @Tron , In 5th gear @ 2.5 k rpm the car could reach only 60 kmph.

    ---------- Post added at 12:26 AM ---------- Previous post was at 12:23 AM ----------

    @ srikar, I will try doing it tomorrow morning b4 heading to sc.
    Last edited: Sep 30, 2011
  6. gurjinder

    gurjinder Staff Member Janitor

    Highly intriguing.

    The shaking clutch pedal is strange. How bad does it shake? Does it shake/vibrate when you press it in?. Do you experience revs climbing high without any increase in vehicle speed?

    A bad MAP sensor can be the culprit but the examiner will tell.

    Good luck. Sad to hear it happen on a new 'Mighty 90'.
  7. kedarbendre

    kedarbendre Esperto

    MH 12
    Touchwood nothing has happened to my 90HP and I hope she will without any problem :up
  8. Srini

    Srini Regolare

    Sorry about the issue Sridhar. Seems to be a minor sensor issue. Do unplug the battery as Srika told. That could solve the issue. However, take it to TASS and analyze the ECU for any error entries. That should have your error recordings which will tell you what the problem is.
  9. looks like ECU had put your car on Limp mode, I guess there is some issue with engine or CR pressure side.

Share This Page