1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

Mamma Mia - White Stallion rides home - BNW Grande Punto MJD emotion.

Discussion in 'Punto 1.3 MJD' started by ghodlur, Jul 9, 2013.

  1. ghodlur

    ghodlur Esperto

    Messages:
    2,326
    Thane
    Post the trip I had to pamper the stallion with the proper detailing. Visited the nearest 3M shop and had opted for a Power Shine package costing about Rs 4300/-. The service at the 3M shop was not that great and I found a lack of professionalism. Lot of young guys working on the car who cared more about being playful than serious work (I guess the absence of the owner was one of the reason for that). The roughness on the roof and bonnet are now gone with smoothness returned. I had to point to the 3M guys about the same on the glass and OVRM's too which had the roughness. They were operating as per the book and no proactive approach. I had to even tell them to clean the alloys. A couple of visible scratches still on the roof which were un attended by the 3M guys. Overall I am happy to see the Punto back in its glory but would not suggest 3M because of the the high cost. No pics post the treatment, but I washed the car yesterday and attaching a few pics of the car.

    P_20160103_110841.jpg

    P_20160103_110859.jpg

    P_20160103_110915.jpg

    P_20160103_110928.jpg

    P_20160103_110945.jpg

    P_20160103_111014.jpg

    MODS: Posted in the wrong thread by mistake. Please move it to my ownership thread. Apologies for the inconvenience.
    --- Double Post Merged, Jan 4, 2016, Original Post Date: Jan 4, 2016 ---
    Thanks Mods for shifting the post which I posted in the wrong thread.

    One thing which constantly irritated me during my recent trip was wet backs. Even though I had AC on, used to feel the wetness on the back. Probably this is due to new seat covers. But is there any solution to this other than having towels on the seats? I am not a fan of those beaded cover either which is supposedly being sold as acupuncture solution.
    --- Double Post Merged, Jan 4, 2016 ---
    PradeepM likes this.
  2. ghodlur

    ghodlur Esperto

    Messages:
    2,326
    Thane
    Today morning when started the car, got the glow plug indication on the MID and was flashing. After about 30 secs of flashing, the indication went off. What does this mean? Do I need to be concerned?
  3. KPR

    KPR Regolare

    Messages:
    400
    TN
    Punto Evo 1.3 90 HP
    @ghodlur I had same issues with Art leather seat covers. With fabric seats? Happy back. One reason I don't want to add any seat cover to my RED.

    Only easy fix is ~ Rs750 beads (not woods). So you take a call. I had some apprehensions about beads. But believe me, it works like magic.
    Option 1 (standard available)Rs. 600-700
    images?q=tbn:ANd9GcSsRHnNP1P8Wo0arz3l7mk_bKauOuG29YhyevKOA4k2RzmviGbV.jpg
    Option 2 (for cars with integrated headrests)Rs.400 max
    images?q=tbn:ANd9GcScrFpLA44Lp0kNFAr3cK7LXiDJH4k5M00QenwzW76FGCB0cRu4QA.jpg
    Last edited: Jan 6, 2016
    ghodlur likes this.
  4. PradeepM

    PradeepM Staff Member Janitor

    Messages:
    705
    Hyderabad
    Linea 1.3
    @ghodlur, I think it's the low temperatures which has caused the glow plug to stay a little longer before it went off. Let me search is I can find anymore information.

    Cheers,
    Pradeep.
    ghodlur likes this.
  5. ghodlur

    ghodlur Esperto

    Messages:
    2,326
    Thane
    Thanks KPR. Option 2 suits the need. I hope these don't become an issue if I drive with shorts. Other wise I will have to request another issue resolution:p:p

    Pradeep, Thanks for the info. Even I thought so. Since today was little bit colder than yday. But then this issue did not appear when I had started the engine during my recent trip where the temperatures were quite low.

    A few Fiat friends suggested to look out for the glow plug timer if it's conked off. :yawn:
    PradeepM likes this.
  6. PradeepM

    PradeepM Staff Member Janitor

    Messages:
    705
    Hyderabad
    Linea 1.3
    Ghodlur,

    You can try those water / gel based seat cushions, they are really comfortable.

    Cheers,
    Pradeep.
    ghodlur likes this.
  7. bibin

    bibin Regolare

    Messages:
    297
    kochi
    @ghodlur,

    i had the same issue.

    Informed FASS in the last service camp, they informed that one of the glow plugs has gone bad, replaced it under extended warranty.

    i believe if your car doesn't have any starting issues then no issues you can change in during the next service.
    PradeepM and ghodlur like this.
  8. avnsiva

    avnsiva Amatore

    Messages:
    140
    Chennai
    Check the glow plugs one by one. Remove the glow plug and connect it to the battery. The end of it will become hot red. If not, then its dead. You can replace it.

    Its usually required when you are living in sub zero temperatures. I am running with this sign for the past year and a half.
    PradeepM likes this.
  9. ghodlur

    ghodlur Esperto

    Messages:
    2,326
    Thane
    Holy cow. Why didn't you replace them during the regular service under warranty?

    The indication appeared just today morning, let me observe of this repeats.
  10. ghodlur

    ghodlur Esperto

    Messages:
    2,326
    Thane
    Few issues cropping up in my Punto:
    1) Noise from the front suspensions (only when the car moves over the speed bumps, potholes or broken roads)
    2) Glow plug issue. Indication goes off after a few secs
    3) Airbag failure indication on MID whenever the engine is cranked. Need to check if the battery is the loose link here.

    Had been to the new FASS in Thane - Life time Mobility. However due to a family emergency could not get the jobs done. Will be visiting coming weekend.

    Had to dash to Pune due to a family emergency. While doing the Thane-Pune run, the car consumed 11.25 ltrs equivalent to one quadrant of the fuel guage (45 ltrs divided in 4 quadrants) which means 11.25 ltrs was used to cover a distance of 180 kms. However while returning from Pune, it took only 5.5 ltrs of half of the quadrant to cover 170 kms. This gives an average of more than 30kmpl. This was with AC at 75% of the journey. But this is based on visual information as seen on the fuel gauge. Actual average will be calculated on tank full basis only.
    mchanna likes this.

Share This Page