1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

Linea T-Jet: "Check Engine" Warning

Discussion in 'Engine Compartment' started by Prithviraj, Mar 11, 2016.

  1. Prithviraj

    Prithviraj Novizio

    Messages:
    27
    Bangalore
    Linea T-Jet
    Hey guys,

    Need your inputs very badly. All of a sudden I'm getting "Engine Check" warning when I tried starting the car today morning and I'm not able to start the car as well.

    I'm literally not sure what has happened as everything was perfectly fine until today.

    Here is what happened today
    - started the car and then it stalled within 10 meters
    - I tried starting the car but ignition didn't work, as well as neither did I see any MID lights coming up which turns ON after you switch the ignition
    - waited for few minutes and tried again turning on the ignition, this time it worked but again got Engine Check warning

    It's parked in my garage now and I'm wondering what to do.

    Have you faced similar issue? Any help here would be appreciated.

    It's just a year old and has clocked only 24k with proper maintenance. (I had it serviced recently as well at 21k)

    Thanks,
    Prithvi
  2. Ravi_M

    Ravi_M Regolare

    Messages:
    323
    Indore
    Indore
    Linea 1.3
    @Prithviraj, I never had such an experience with my Linea 1.3 MJD and I am not a knowledgeable person about cars in general, but common sense hints at the wiring infidelity or problem of chocked exhaust. Do you have pests / rodents in the area? Have you or neighbors ever faced pest problem before ? A car parked in your garage shall not turn hostile in a night.

    Experts / Experienced members?
  3. Prithviraj

    Prithviraj Novizio

    Messages:
    27
    Bangalore
    Linea T-Jet
    @Ravi, yes few of my neighbours have had rat issues so yes I second your opinion. Just came to service centre and some strange thing happened. The warning is no more coming, however as a precaution I'm still getting it checked to be on the safer side. My finger crossed
    PradeepM likes this.
  4. Prithviraj

    Prithviraj Novizio

    Messages:
    27
    Bangalore
    Linea T-Jet
    Finally bit of relief.. They diagnosed and deleted a software error.. Thanks all for the help
    varunrtr likes this.
  5. Prithviraj

    Prithviraj Novizio

    Messages:
    27
    Bangalore
    Linea T-Jet
    Hey guys running into issue again. Today morning when I switched on the ignition, MID did not light up and was completely shut.. And also Car didn't start..

    Remote lock too was not working.. However I just opened the door and closed it back and then the tried starting the car.. This time MID worked and car too started..

    Any idea what's happening?
  6. RaviHegde

    RaviHegde Regolare

    Messages:
    299
    Karnataka
    14.62°N 74.85°E
    Grande Punto 1.4
    Fact that remote lock too did not work and MID did not light up indicates it is a battery issue. Very likely the battery has some lose contact. Ensure both the battery connector posts and connector clamps are clean and secured properly. Another possible issue is some lose contact within the battery which will need battery replacement.
  7. Prithviraj

    Prithviraj Novizio

    Messages:
    27
    Bangalore
    Linea T-Jet
    Hey Ravi, yes I had it checked at Fiat and they said everything looks fine and it's probably due to battery. Problem didn't exist after that day however I'm going to get the battery replaced
  8. viveksonkhla

    viveksonkhla Amatore

    Messages:
    232
    Noida, India
    NCR
    Linea T-Jet
    Get your battery terminals cleaned and check them if they fit alright. Take the car to a local mechanic if you need....I had similar problems ... it got sorted with a bit of cleaning and couple of screw getting tightened...

    Do write back if you still face the problem.

Share This Page