1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

Linea MJD - Turbo Pressure fault.

Discussion in 'Engine Compartment' started by Sanj1ay, Jan 5, 2011.

  1. Sanj1ay

    Sanj1ay

    Messages:
    5
    Indore
    Hi!

    I am new here. Been a proud owner of a Linea 1.3 MJD Emotion Pk since May 2009. I have clocked 24000km on it which includes a few long road trips (1200 - 4700km).

    On my last trip out on Dec 30, after going about 50km from home, I felt a slight jerk in the drive (which I later understood was because of the Turbo switching off), a beep with "check engine" in the display, and the engine warning light continuously on. Car suddenly felt extremely sluggish, pick-up very poor & it refused to go above a certain speed in any gear (80-90 in 4th & 120 in 5th after a prolonged period of acceleration).

    I stopped the car after a few kms, turned it off, & then on again... light was gone & turbo was back! another 6-7km & the same thing again (beep, check engine & engine light.. loss of power). After a few tries of turning the car off & on, and then loosing power again, I decided to just drive without the turbo to the next big town to have it checked at a Tata-Fiat Service center.

    They plugged in the car to their diagnostic computer & it came up with an error "Turbo Pressure". The mechanics checked the turbo tubings & said it seemed fine, they decided to take a test drive with the computer plugged in, & see what happens when the fault comes on. Fault came on in the same way (beep... etc) computer again said "Turbo Pressure" now the turbo lines had no pressure / vacuum, & we came back to the service center. After much consultations, they were still not sure of what the problem was. They wanted to change one part... go for a test drive... then change another part etc..

    By this time, it was already past 2pm & we had another 450km of bad roads to negotiate to our holiday destination. We were all loosing patience, and the mechanics were not sure of what they were doing, so we decided to get on with the trip without any turbo power. Over the next 1200 kms, I managed to keep the turbo mostly on through what i called 'controlled aggression'! (I realized that the fault would not come under calm driving conditions with low revs and max speed upto about 120 & no sudden acceleration for overtaking.)

    The fault still comes when the revs are pushed for a quick pick-up & it resets every time the engine is turned off.

    Anyone had a similar problem or know what is going on? Any help will be appreciated.

    thanks.
    Sanjay.
  2. Ravi

    Ravi Staff Member Janitor

    Messages:
    6,001
    Bangalore
    Grande Punto 1.3
    I don't think anybody has faced this issue. Get it checked at some good service station in your area. Keep fiat officials in loop so they are aware of what is happening. SC mechanic might not be aware of this kind of issue, so Fiat help would be required.
  3. bhai

    bhai Esperto

    Messages:
    1,183
    Ahmednagar
    Grande Punto 1.3 90 HP
    ::pP
    This problem is just like topic " Loss of Power" by amolmane.
    Only differance is Sanj1ay's Linea is alarming ECU error code.
  4. Narayan

    Narayan Regolare

    Messages:
    282
    Chennai
    Hi, this seems to be a peculiar issue that i have not come across anyone complaining yet. (@Bhai, i think i had not read the post that you had shared). Looks alarming though.

    Please keep us posted with your findings from a good TASS and also the response form Fiat.
  5. Sanj1ay

    Sanj1ay

    Messages:
    5
    Indore
    I went through the entire "Loss of Power" thread before starting this thread.

    Amolmane's car seems to have a different problem than mine. The turbo in my car turns off while driving (with engine warning light) & comes back on when the engine is switched off & on again.
  6. bhai

    bhai Esperto

    Messages:
    1,183
    Ahmednagar
    Grande Punto 1.3 90 HP
    @ sanjay
    Turbo never goes off till you do not stop engine. Your Boost Pressure Sensor/MAP Sensor may be culprit. Because of faulty Boost sensor,ECU may be getting wrong signal. Faulty MAP sensor can't count the proper amount of air entered into Intake Manifold.
    So Injectors may not be sprayed enough amount of Fuel.
  7. bhai

    bhai Esperto

    Messages:
    1,183
    Ahmednagar
    Grande Punto 1.3 90 HP
    Linea has VGT (Variable Geometry Turbo Charger).
    In VGT,angle of turbo blade varies as per change in exhaust pressure. So possibility is

    Turbo Angle may not be vary as per variation in exhaust pressure because of any mechanical problem in Turbo or its blades.
    So Boost pressure is detecting the fault.& when this problem/fault signal goes to ECU,ECU is alarming Turbo Fail warning. Check the Turbo.

    If you are not following turbo Rule :- In city run the engine at Idle for at 30 Sec.before stopping
    & on highway cruise,run the engine on Idle at least 1 min. to prevent Turbo damage OR Turbo Oil Starvation.

    then possibility of damged Turbo.
    When the warning light glows,rev the engine at high RPM. If the black smoke is there then Turbo may be culprit.
  8. amogh

    amogh Staff Member Janitor

    Messages:
    1,377
    Pune
    Grande Punto 1.3
    @sanjay
    What is the current status ? Is your car at the service center in your home town ?

    As far as I know nobody on the forum has had this problem before.

    My suggestion : don't get into self diagnosis mode or try too many things suggested on various forums. Your car is in warranty and let the manufacturer take care of it.

    As Ravi has rightly suggested keep Fiat in the loop by sending an email to service@fiapl.com.

    And do keep this thread updated
  9. bhai

    bhai Esperto

    Messages:
    1,183
    Ahmednagar
    Grande Punto 1.3 90 HP
    @Sanj1ay

    Any update about the dignosis of your problem ?
  10. Sanj1ay

    Sanj1ay

    Messages:
    5
    Indore
    Thanks all for your inputs.

    The car is still with me as the Tata-Fiat dealer in my city has a very poor service & is not at all trustworthy. Till now, I have never gone to them & prefer to drive to other places for service.

    When I get some time, I will drive 200km to Bhopal & have the problem resolved there. I guess it wont be happening in a hurry!

    will keep you posted,
    thanks.

Share This Page