1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

Linea Horn Switch Pad Issue - Resolved - Now Resurfaced

Discussion in 'Electrical Systems' started by Viny, Nov 19, 2012.

  1. Viny

    Viny Esperto

    Messages:
    1,742
    :)
    Less than 20,000 Kms
  2. VahanPujari

    VahanPujari Staff Member Janitor

    Messages:
    2,303
    Mumbai
    Aah that's it? You mentioned you have not heard fron Fiat. I would be very eager to know how this part failed though am 200% sure it won't come. Why I am eager is as there is no way TASC is involved and can be blamed. And how much rough can you use horn? Unless you poured some liquid on steering. Atleast I have not done it nor allowed cleaning with any polish.
  3. Viny

    Viny Esperto

    Messages:
    1,742
    :)
    We dont use any liquids inside the car. I dont drive with open windows, Nor do I polish interiors as dashboard reflects on the front glass. And not to say, I being Linea owner, we always take extra care isnt it. I think even if we drop complete 1ltr of liquid on steering, i dont expect even single drop will reach to the location where the copper wire strip is. Also i dont think amount of horn usage would impact it, its material failure. And I generally dont use horn unless someone decide to commit suicide in front of my car.

    I dont say the service team is anywhere responsible for this, what i am saying is that this a product design and development failure leading to such a scenario.

    Our preliminary assumptions is one of the two copper rods used in the circuit is of poor quality as that caught the rust and turned green where as other one next to it is still holding good. You can see the same in the picture that i have posted.
  4. VahanPujari

    VahanPujari Staff Member Janitor

    Messages:
    2,303
    Mumbai
    ^^
    That's why I'm very eager to know from Fiat how this part can fail.
  5. Viny

    Viny Esperto

    Messages:
    1,742
    :)
    Well I will update the same, provided they answer it :p
  6. pioneeraaron

    pioneeraaron Superiore

    Messages:
    716
    Mulund/Mumbai
    Guys! Me too in the league :( Im too having this Horn pad problem.Did 2 times the setting at TASS.The left portion seems dead when pressed.Sometime comes back to life.Irritated and frustrated im using the bottom most and right portion to blow horn now :D
    Last edited: Nov 22, 2012
  7. Viny

    Viny Esperto

    Messages:
    1,742
    :)
    :( List goes on ...
    Serious problem is that when you are turning and want to honk, you are in no position to figure out where to push to get it working, could lead to a disastrous situation, Given that we have a horn driven society and every one is lord of the road.
    Last edited: Nov 22, 2012
  8. Italia-Linea

    Italia-Linea Staff Member Janitor

    Messages:
    2,123
    Pune
    I honk 100 times in a day atleast. Till date i must have honked lacs of times. I am not yet facing any issue. Seems it got corroded due to moisture or something?
    1 person likes this.
  9. VahanPujari

    VahanPujari Staff Member Janitor

    Messages:
    2,303
    Mumbai
    Aaron,

    As I mentioned earlier, get that ring underneath horn pad checked alongwith 3 small copper strip. The copper strip on the left side may have got broken. The part should not be costly.
  10. OCTANE

    OCTANE Amatore

    Messages:
    75
    Cochin
    Add me too into this issue. Rightside of my hornpad had stopped working last year and this year issue came up with the left side also. Gave it to Concorde and they changed something and horn seems to be working fine now. It isn't covered under warranty it seems. Just like vinys Linea my too has just done 19k kms.

Share This Page