1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

Linea 1.3 wont accelerate past 2000 RPM

Discussion in 'Engine Compartment' started by Sandeep Alexander, Jul 17, 2015.

  1. Sandeep Alexander

    Sandeep Alexander Timido

    Messages:
    13
    Hyderabad
    Hyderabad
    Linea 1.3
    Hello Everyone,
    My Linea 2013 Emotion Pk just completed 44K kilometers and was sent in for the 45k service and since this was around its second anniversary, got the recommended 2 year Oil change done. Service was swift at Butta fiat hyderabad and car was handed over within 6 hours time. The problem starts here... the car post service just does not cross the 2000 - 2500 RPM in any gear. Very sluggish to drive and very unnerving in traffic. Tried to switch off the car and restart hoping for normalcy to be restored but in vain...the RPM however goes upto 5000 RPM when in neutral. There is ZERO turbo boost, no smoke coming out (white/black). No warning lights lit up on the dash board. I intend to take the car back tomorrow to the service center.
    Request your comments/feedback on the possible causes of this issue.
  2. kishorekrs

    kishorekrs Amatore

    Messages:
    128
    Bangalore
    Punto Evo 1.3
    There must be some problem with the turbocharger I guess. Get it checked in FASS once.
  3. Sandeep Alexander

    Sandeep Alexander Timido

    Messages:
    13
    Hyderabad
    Hyderabad
    Linea 1.3
    Yes Kishore Krs, I fear its the same, can anyone suggest if needed, will the turbocharger be covered under warranty?
  4. kishorekrs

    kishorekrs Amatore

    Messages:
    128
    Bangalore
    Punto Evo 1.3
    I am afraid its covered under warranty. Since its mechanical issue I don't think if they would cover under warranty buddy.
  5. Sandeep Alexander

    Sandeep Alexander Timido

    Messages:
    13
    Hyderabad
    Hyderabad
    Linea 1.3
    I hope it is, either ways the ECU should be throwing up a warning light in case if a turbo fail or if there is a pressure leak. I this case there is no indication from ECU. Hope the mechanics at FASS will be able to sort this out.
  6. kishorekrs

    kishorekrs Amatore

    Messages:
    128
    Bangalore
    Punto Evo 1.3
    It may not be due to turbo fail mate. Technically speaking yes ecu should throw some warning signs but over here it could be some component issue. Issue could be with either seal gasket or it maybe due to misalignment in fitting the component itself!!
    Sandeep Alexander likes this.
  7. KKAUL

    KKAUL Amatore

    Messages:
    204
    delhi
    Grande Punto 1.3
    If ECU is not throwing any error then please check the clutch
  8. Sandeep Alexander

    Sandeep Alexander Timido

    Messages:
    13
    Hyderabad
    Hyderabad
    Linea 1.3
    Hello again,

    Just called up service advisor who dealt with my car when serviced, I explains the issue to him and he asked e to bring the car over tithe FASS on Monday, also when asked he advised that turbo is covered under warranty.
    @ Kkaul will have the clutch check as well. Hope the Butta service in hyderabad will sort this problem out soon.
    --- Double Post Merged, Jul 18, 2015 ---
    Took the car out today to see how it performs on the highway, acceleration speeds as below
    1st gear- 20 kmph
    2nd gear - 30-40 kmph
    3rd gear - 40 kmph
    4th gear - 80 kmph max after prolonged acceleration
    5th gear - 100-120 kmph after never ending acceleration
    Note the rpm reading in 4th and 5th gear did not cross 3000 and the engine was sounding as if I had redlined the RPM to its max...
    Last edited: Jul 18, 2015
  9. kishorekrs

    kishorekrs Amatore

    Messages:
    128
    Bangalore
    Punto Evo 1.3
    Hi @Sandeep..well its gud to hear that the turbo is covered under warranty. I hope the FASS would rectify the issue clearly. Do keep us updated about the issue post checkup mate.
    Sandeep Alexander likes this.
  10. Naughty

    Naughty Superiore

    Messages:
    600
    Ahmedabad
    @Sandeep...

    I think it's coz of turbo hose pipe... It must not be fitted properly or it must be cracked... But in that case it should throw black smoke from exhaust on acceleration... If its the issue of turbo or turbo hose pipe... That will be covered under warranty...

    Do update here once you get the solution.

    Cheers...

    Neel
    Sandeep Alexander and prabhjot like this.

Share This Page