1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

LHS rear indicator does not work at times

Discussion in 'Electrical Systems' started by Cinju, Oct 31, 2013.

  1. Cinju

    Cinju Esperto

    Messages:
    1,333
    Trivandrum
    Hi,
    Intermittently I am getting warning on the MID asking me to check LHS rear indicator. When this warning comes, I can even see the indication in the instrument panel blinking fast which is a clear case of a faulty bulb. But why is it happening intermittently. ? All of a sudden it works normal. Can somebody get me the exact fuse number for the LHS rear indicator ( I did check Punto manual pdf document. But was not able to trace the same) ? A faulty contact could also lead to this which I will soon be checking. Anything else that need to be checked ? Are there any chances of short circuit ?

    Thanks,
    Cinju.
    Last edited: Oct 31, 2013
  2. Check the wiring harness first.second replace the bulb.
  3. pdash

    pdash Regolare

    Messages:
    382
    Bangalore
    Mahadevapura
    Grande Punto 1.3
    I had similar experience with with left brake light. I saw one error in the dash board(Active model just glows one light in the dash board) and after couple of days it disappear. One day when I was parking in a mall I notice that one of my brake light was not glowing in the mall Glass wall and dash board light glows. Took it to FASS (KHT), the checked and said there is a loose connection. Repaired immediately with out any charge.
  4. Cinju

    Cinju Esperto

    Messages:
    1,333
    Trivandrum
    Thanks fellows. Sat even the bulb can cause such an issue ?

Share This Page