1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

HU Keeps switching between input Source-USB/Radio/CD

Discussion in 'In Car Entertainment' started by Akshay4384, Jan 26, 2012.

  1. Akshay4384

    Akshay4384 Superiore

    Hey guys,
    I have a Linea MJD EPK.
    Off late i have been facing this problem with HU,that it keeps on switching between sources-like from Media player to tuner to CD and back and forth randomly on it own,since every function works,it seems more of a software problem to me.
    Has anyone else faced it?
  2. Jotinder

    Jotinder Regolare

    Messages:
    308
    New Delhi
    Linea 1.3
    Try resetting your ECU and B&M by unplugging negative terminal for 10-15min. It usually works if B&M startes behaving erratically.
  3. Akshay4384

    Akshay4384 Superiore

    Did that already-didnt work.
    Just updated to latest version of Blue and ME-lets see if this works.
  4. Viny

    Viny Esperto

    Messages:
    1,742
    :)
    Akshay,
    Welcome to TFI :)
    B&M upgrade would not help in this case, but yes that would be helpful in other connectivity related solutions.
    It would be logical to check the HU connectors, a lose connection could result into transmitting of false values/commands.
  5. vIjAy_kHaSa

    vIjAy_kHaSa Esperto

    Messages:
    1,352
    Panchkula
    Have you tried another pen drive if yes, it sounds like a damaged usb port to me
    Loose connection would have resulted in ODO km reading to flash.
    Last edited: Jan 26, 2012
  6. Toruk_Macto

    Toruk_Macto Amatore

    Messages:
    205
    Ghatkopar-Mumbai
    Hi Akshay,

    I've experienced it few times and i found the reason very funny. Lower part of my right thumb kept touching the OK button (Upper right most button) on the steering wheel and it kept changing the source. It happened especially while turning (My thumb used to get tight on the steering). Check if this is the reason.
    Last edited: Jan 27, 2012
  7. kirenh

    kirenh Regolare

    Messages:
    421
    Mumbai/Pune
    Pune
    Grande Punto 1.3 90 HP
    I also have the same problem along with a problem of radio reception. The unit keeps searching for the radio signal repeatedly. My car is at present at the SC and they are checking the same. Hope they are able to rectify it.

    Kiran
  8. Akshay4384

    Akshay4384 Superiore

    Thanks for your help guys:)
    Problem resolved after i updated the Blue and Me
  9. Hey Akshay,

    How and where from did you update the Blue&Me software? Please enlighten us.

    TIA.
  10. Akshay4384

    Akshay4384 Superiore

    hey Vikram,i downloaded it from the link found elsewhere on the forum.

Share This Page