1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

High Engine Temperature Warning

Discussion in 'Engine Compartment' started by govind, May 9, 2016.

  1. govind

    govind Timido

    Messages:
    8
    Chennai
    Chennai
    Linea 1.3
    Hello Everyone
    I have a Black Fiat Linea 1.3 MJD. Have done close 55k in the last 5 years. A great run so far.

    Took the car on a long drive covering 1400 kms in and out of the ghats around Kumily, Thekkady, Vandi periyar over the weekend

    At the ghats I did notice an extra humming noise, the one we normally hear when the AC runs. The only difference is that this noise was now coming without the AC. I opened and checked it and didn't notice any difference and figured out that it was coming from the radiator or something that was over working.

    Drove back to Chennai yesterday without any problems. The noise was still there though. However late in the night at 1 AM when I took it out I suddenly got the ' High engine oil temperature' and the dash board alert asked me to switch off the vehicle. By this time the engine temperature had crossed the middle dial. I switched it off for a couple of minutes and restarted it. Didn't see the warning and took the car home ( hardly 2 kms from the place where i had stopped)

    Need help and advice on whats the potential issue and way out ? More frustrating because I had taken it to Ramkay Fiat for a checkup the previous day I drove out. They had replaced the turbo hose and a dozen clips, citing engine oil leak.
    Exact parts replaced:
    1. EGR Valve Heat exchanger connection pipes assembly
    2. Pipe between turbochargers and heat exchanger

    Has anyone faced this kind of issue before ? Kindly give me your inputs so that I can navigate the wonderful world of service engineers :):angelic:

    thanks
    govind
    Last edited: May 9, 2016
  2. PradeepM

    PradeepM Staff Member Janitor

    Messages:
    694
    Hyderabad
    Linea 1.3
    @govind, should be an issue with the radiator fan. Kindly have the connection checked. In case of any loose connection the fan would not rotate and the engine temperature shoots up.

    cheers,
    pradeep.
  3. Anup

    Anup Regolare

    Messages:
    303
    Bangalore
    Bangalore
    Grande Punto 1.3
    Looks like more to do with a Sensor issue, the Fan wouldn't have stopped function, if it was you could clearly see the temp needle go all the way near the H mark and a RED LED would have been seen.
    Only a examiner should tell what went wrong, first you need to check for the error, I am sure it must have got recorded, if not then the second step need to on the diagnostics options, you need to check for Temp Sensor and run the test.
    PradeepM likes this.
  4. PradeepM

    PradeepM Staff Member Janitor

    Messages:
    694
    Hyderabad
    Linea 1.3
    @govind, please let us know the latest status on the issue.

    Cheers,
    Pradeep.

Share This Page