1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

High Beam working but low beam does not!

Discussion in 'Electrical Systems' started by Prash1407, Aug 6, 2014.

  1. Prash1407

    Prash1407 Amatore

    Messages:
    68
    Bangalore
    Friends,

    I am facing a peculiar problem since 2 week. After my transfer from Bangalore to Pune, I got my car here 3 weeks back. I used to commute to office everyday and never faced any issue. Suddenly one day, I switched on the lights and it didn't light up. I checked the high beam and it did which confirmed that there is no problem with the bulb. In the weekend, I went to Pandit Auto for wiper change and check of headlights and bingo!!! it works there properly:eek:.

    After two days, the same problem again!! I did not bring the manual from Bangalore :A because of which I could not check the fuses. I had thought that the problem is with the fuse.

    Today, went to Sky Moto (since it is near to my place) and got it checked. All the fuses in both dashboard and bonnet were checked. As per the adviser, there is no problem with the fuse and bulbs. He was suggesting that since it worked for some days in between, there may be some connection issues. As per him, the two components; BCM and Multifunction switch need to be checked (one the indicator and light knob and the other behind the dashboard fuse) and this may take a whole day. Since the car is still under warranty, any replacements will not be an issue, but wanted to check few things:

    1. Has anybody faced this problem and how was this rectified?
    2. As per the technician, the grounding is not happening properly for the low beam but happening for the high beam ( I was confused since there is only 1 bulb for both). What could be the technical issues?
    3. I have read that Pandit Auto is very good in Pune, can I trust Sky Moto for this issue?

    :eek:fftopic
    I reached Sky Moto at the closing time (around 5:45pm) and the adviser Mr. Rhushikesh was very helpful in checking this till 7:00. He told that this will take some time but, came back again and checked the other stuff to pin point the correct problem. I would say that it was a very good gesture from him.
  2. kailasmenon2000

    kailasmenon2000 Superiore

    Messages:
    609
    Chennai
    Fuses you meant included relays? I had the same problem yesterday. Changed a defected relay & everything is perfect now.
    1 person likes this.
  3. Prash1407

    Prash1407 Amatore

    Messages:
    68
    Bangalore
    Yes, the relays were also checked and as per the adviser, there is no problem with them.
  4. murugusec

    murugusec Timido

    Messages:
    18
    CHENNAI
    one year back i had this problem and it was rectified by RDC-chennai. The technician told it was loose connection.
  5. Ravi

    Ravi Staff Member Janitor

    Messages:
    6,001
    Bangalore
    Grande Punto 1.3
    Advisor didn't tell you where is the problem then?
  6. Prash1407

    Prash1407 Amatore

    Messages:
    68
    Bangalore
    He did check the fuse and relays in both the fuse boxes and told two possibilities:
    1. Loose connection somewhere
    2. Need to check the BCM and multifunction switch. (for which a lot of time is required)
    1 person likes this.
  7. Prash1407

    Prash1407 Amatore

    Messages:
    68
    Bangalore
    Update!!

    I had been to Sky Moto for the check of the headlight. They replaced the BCM from another Punto and the headlight worked. They conculded that the BCM is gone kaput.

    Till now ok, but one week before this check, when I was driving, I just switched on the light to check and voila it switched on... So I thought the problem should be some loose connection. When I told them this, I was told that the BCM was in the last stage of life and now it is gone kaput. I was not satisfied with the answer and have decided to get this checked again at Pandit Auto.

    Before that, need suggestions from the guru's here. Is it possible for the BCM to go kaput and the lights switching on once in random? All other controls are working fine without any issues.

    Also, for this process of around 3 hrs, there was a labour charge of Rs 280. During warranty period (car brought in Feb 2013), do these charges apply? I remember getting small things done at Vecto without any charges.

    Please suggest
  8. sakthirajs

    sakthirajs Timido

    Messages:
    1
    Chennai
    Hi Prash1407,

    I am also facing the same problem in my punto 1.3 emotion, high beam is working but low beam is not working . I checked the car in Ramkay Fiat in Perungudi, Chennai and the technician there told me that the problem is with the BCM. And it may cost around 20K to replace it. The car is not in warranty period now. So I am very confused . Is there any other simpler solution to this problem? Like having a seperate wiring directly from Battery?(Sorry if I sound silly).. Or can I drive with High beam all the time along with the fog lamp switched on. Is it safe?

    I am very reluctant to spend that much for the low beam.

    Please suggest.

    Thanks much.

Share This Page