1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

Glow plug warning

Discussion in 'Electrical Systems' started by jimmy, Sep 11, 2010.

  1. Fiat-Yamaha

    Fiat-Yamaha Superiore

    Messages:
    521
    Bangalore
    Had planned to visit vecto tomorrow for glow plug replacement.
    Something miracle happend. Since yesterday mrng aft Low fuel warning started Glowplug warning is disappeared:confused:
    Filled the tank in morning did some runs but still no warning is back. Is all plugs r ok?
    Vll wait for the warning nd watch:rolleyes:

    Sent from my GT-I9100 using Tapatalk 2
  2. pdash

    pdash Regolare

    Messages:
    382
    Bangalore
    Mahadevapura
    Grande Punto 1.3
    I saw the yellow light today, it came and stays for 5 mins during that time I was in traffic signal with full rain.

    Switch off the engine and start again, it did not disappear. I continue to drive, after few mins it disappers automatically. Is this normal???
  3. Akshay4384

    Akshay4384 Superiore

    Yes,the light goes off after blinking for approximately 2 mins,and will come up next time you start the engine.
  4. Fiat-Yamaha

    Fiat-Yamaha Superiore

    Messages:
    521
    Bangalore
    Aft getting low fuel warning yesterday, got the tank filled.

    Now I dont see any glow plug warning which was frm past 1week:confused:

    Is everthing(glowplugs) ok?im confused now.

    Sent from my GT-I9100 using Tapatalk 2
  5. pdash

    pdash Regolare

    Messages:
    382
    Bangalore
    Mahadevapura
    Grande Punto 1.3
    Today morning yellow light glow again. I drove for 1.5 hours. The light is still glowing.

    Checked the user manual yesterday night, it says that this light glow only when there is an external light failure. I checked all the lights are working fine including number plate light. Now I am little scare, pls help
  6. pdash

    pdash Regolare

    Messages:
    382
    Bangalore
    Mahadevapura
    Grande Punto 1.3
    yellow bug

    This pic scaring me from yesterday night . All the external lights seem to be working OK.
    Any idea how to resolve this. is this any serious thing

    IMG_20130521_103940.jpg
  7. venka

    venka BANNED

    I also get this warning when ever my rear no plate lights are not working , once i tap on them and they start working. Once Tata indica rear ended my punto , From that time onwards i am observing this.

    Here in your case not sure what is the cause for this.
  8. cooltaurean

    cooltaurean Amatore

    Messages:
    90
    Mumbai
    The whole issue with extended warranty covering the glow plug is that tass put up the claim for glow plug (even when they have stock) to fiat only after u reach out to them with a copy of the extended warranty document. This has taken a whole day in my case at fortune motors powai. Even late evening they told me approval was not received. So it spilled into day 2.after replacing they said if the issue reoccurs in 6 months they will replace for free but it will still take a day as they have to go via same process as mentioned above. Note that they take labour charges though, per plug....
    My point is, can someone please explain why these go bad and what can be done /checked to avoid this.

    Sent from my GT-N7100 using Tapatalk 4 Beta
  9. Sathish_UPS

    Sathish_UPS Novizio

    Messages:
    33
    Bangalore
    Even I faced same issue a year back, displayed 'Check Glow Plug' warning for 2~3 days & later vanished for a week & then again appeared continuously after that. Checked with KHT, problem found to be with glow plug timer & changed it in extended warranty [Initially SA told me that it wont be covered in extended warranty & later accepted after I showed him the warranty booklet].
  10. livelyyoungman

    livelyyoungman Regolare

    Messages:
    428
    Chennai
    Chennai
    Linea 1.3
    Just seeing the GLOW PLUG message!!!!
    It popped after the battery change. Will be taking this as part of the yearly service which is due very shortly.

    In fact the message is not displayed the first time when I start my car in the morning; but is displays all during the day after any stop.
    Last edited: Oct 17, 2013

Share This Page