1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

Glow plug warning

Discussion in 'Electrical Systems' started by jimmy, Sep 11, 2010.

  1. jimmy

    jimmy

    Messages:
    8
    Bangalore
    Hi All,


    I have an issue with the glow Plug Warning lamp in Fiat Puto which I got recently. Once the car is started, the glow plug warning lamp starts blinking for almost 30 seconds and goes off. As per the manual, we are supposed to take it to the service station. But when i checked in the net, i have seen people facing similar issues. But in this forum, I couldn't see anybody with this issue. If anybody knows about the same, please help me to resolve the same. My punto has done only 900 kms.

    Rgds

    jimmy
  2. royj

    royj Esperto

    Messages:
    1,306
    Trivandrum
    Welcome to Team Fiat.
    Why don't you get it checked out at the service station. Since I haven't come across anyone with a similar issue, I can't comment on what the problem might be. ::pP
  3. extr3mex

    extr3mex Amatore

    Messages:
    106
    Cochin
    hey are u talking bout a yellow bulb like thing near the speedometer? BCoz I have seen that thing glow up sometimes and I had no clue why..I asked one of my friend in the service station and he told me it may be something related to the chip.
  4. jimmy

    jimmy

    Messages:
    8
    Bangalore
    Glow plug lamp is a yellow color one which has the shape of a coil. If searched in google, you will get the image of that. This plug is actually used to heat the engine, before injecting the fuel. This plug will start working when the key is on position. After all these lights gopes off we start the engine. In case if the engine is cold, after starting also some more time this lamp will glow, which indicates that the glow plug is still working to keep the engine in a favourable temprature for a smooth compustion to happen. But as per the manual. The behaviour like this must be immediatly addressed, by thaking to a service center. If anybody in this forum have faced this issue or similar kind, please let me know, how to get rid of this issue.
  5. Chaos

    Chaos Regolare

    Do you crank the engine when all the required lights are off?? (including the heater coil) and let the car run idle for 30 seconds or so for the engine to warm up??
    Does the light pop back up again after the engine has fairly warmed up?? (quarter way temp needle position)

    If the light pop back up again while driving... then..
    I suggest you visit the nearest TASC and if they decide its a normal operation, show them the manual where its mentioned it needs immediate attention.

    Thats all we can do from here.. No DIY solution for that..
  6. jimmy

    jimmy

    Messages:
    8
    Bangalore
    Once started, it will blink for some time and goes off. This is not happening while driving. So let me check the way, what you have told and will get back. Anyway i will take it for a check up and figure out what is the issue as well.
  7. arulvr

    arulvr Amatore

    Messages:
    108
    Bangalore
    Jus curious to know if this has been resolved ? Keep us posted ..
  8. jimmy

    jimmy

    Messages:
    8
    Bangalore
    Once rectified, I will definetly keep the forum updated.
  9. jimmy

    jimmy

    Messages:
    8
    Bangalore
    Has been resolved, be erasing the error code in the system
  10. amolmane

    amolmane Guest

    To
    Jimmy

    What was the name of error regarding Glow plug ?
    What was your odometer reading at the time of error ?

Share This Page