1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

Fiat Punto 1.4 Emotion Pack 2009 model - Blue&Me Toast

Discussion in 'In Car Entertainment' started by Sumit Simlai, May 16, 2015.

  1. Sumit Simlai

    Sumit Simlai Timido

    Messages:
    4
    Ghaziabad
    Hi
    Since I have to be driving a lot daily, the phone and music is a necessity. Of late I landed into a very difficult situation wth my B&M. I think it is dead. It happened like this. Since the past couple of weeks, I would notice that the song being played from the USB port would just stop and the audio would changeover to radio. I thought may be there could be some error in the USB, which I would try and correct using a laptop. Last week, the odometer started flashing. I remembered that the last time this happened was about a year or so ago and before I sent the car to the garage I would try the internet suggested method of removing the battery terminal and plug it back in after about half an hour. It worked then. But not this time.

    I also noticed that the display on Blaupunkt system shows AUX. Didn't understand what it meant but slowly I started realising that perhaps the B&M unit has gone toast. Also none of the B&M buttons on the steering work.

    Being an engineer myself I thought let me at least check the module. I opened it and found one of the chips on the PCB sort of burnt (well, not very sure). Am uploading a pic.

    I was told by the dealer that the part will have to be ordered and would cost about INR 12.5k. My question to the forum therefore is whether it is advisable to buy from eBay (assuming I find the same part number), or, is it possible to find just the PCB somewhere, or should I order and wait for the part to come from Pune? Could a wiring problem cause this burnout?

    Currently I am driving without the module plugged in.
    Any advice would be appreciated.

    WP_20150515_21_11_32_Pro-1.jpg

    WP_20150515_21_05_08_Pro.jpg

    WP_20150515_21_00_44_Pro.jpg

    WP_20150515_21_11_32_Pro.jpg

    WP_20150515_21_00_21_Pro.jpg

    View attachment 79723

    View attachment 79724

    View attachment 79725

    View attachment 79726

    View attachment 79727

    View attachment 79729

    View attachment 79730

    View attachment 79731

    View attachment 79732
  2. harryaviator

    harryaviator Regolare

    Messages:
    341
    kochi
    kochi
    Linea 1.3
    since u have confirmed that the B&M unit has gone kaput, ucan try replacing individual components. it may work.
  3. Sumit Simlai

    Sumit Simlai Timido

    Messages:
    4
    Ghaziabad
    Well that's not possible since the PCB is a doublesided one. Moreover, FIAT should tell me the reason for this failure and burnout which they are unable to tell. They just replaced the blue and me, did something called proxy alignment and gave me the car back. And lo behold, while the stuff has started working but not like before. suddenly in the middle of a song the blue&me will switch over to radio. It seems now to me that the SRC / OK switch is working on its own and causing the changeover. Anyone any ideas?
  4. asimpleson

    asimpleson Esperto

    Messages:
    3,000
    Heptanesia
    Linea 1.3
    Try disconnecting the steering remote connection, maybe its a dumb idea. But worth a shot? @Sumit Simlai
  5. Sumit Simlai

    Sumit Simlai Timido

    Messages:
    4
    Ghaziabad
    Well, how should I do that? And then without the button how should I test whether the problem gets resolved?

Share This Page