1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

Fiat Linea Tjet: AC trips after driving 6-7 KM.

Discussion in 'Technical' started by viveksonkhla, May 9, 2012.

  1. vIjAy_kHaSa

    vIjAy_kHaSa Esperto

    Messages:
    1,353
    Panchkula
    This is how the sensor have to checked according to Fiat
    Using a multimeter, check with the ignition key in the ON position between pins 1 and 4 and between pins 3 and 4 of the solar sensor
    The voltage is proportional to the thermal energy present on the windscreen analyzed by the sensor photodiodes: there should be a signal of less than 5 Volt (between 4.5 V - minimum solar rays - and 0.5 V - maximum solar rays).
    If there is a problem, using a multimeter and disconnecting the sensor, check the sensor power supply connector [EL_K090], with the ignition key in the ON position between pins 1 and 4 and between pins 3 and 4 is about 5 Volt.
    Last edited: May 11, 2012
  2. ENKI

    ENKI Esperto

    There could be lots of reasons. For eg. ice deposited around cooling coil due to leakage & that's when AC trip due to faulty reading in temp. drop. I have encountered this problem in window AC & my earlier car too & they trip after sometime. When the ice melts aftersometime, compressor switches on again & works till ice gets deposited again.
    I think you should take it to TASS.
  3. viveksonkhla

    viveksonkhla Amatore

    Messages:
    232
    Noida, India
    NCR
    Linea T-Jet
    Alright folks....problem solved:

    Issue: ACC stops working after driving 20min or so in hot sun....then compressor would start kicking in and turning off randomly at different speeds...and times.

    Diagnosis: Gas overfilling in the AC system created reverse pressure in the system which in turn confused ECU which gave wrong signals to compressor. I fought with them if it was a sensor problem.... but I was wrong.

    Reason: In during second service .... Sterling Automobile team replaced O-ring in my AC system then refilled gas...in fact the overfilled it... thus this issue.


    Resolution: Oberoi Motors Noida...the team cleaned the AC system and flushed out all gas ..and then refilled the same to optimum level.. all is working well so far...

    $$$ : Zero(Work done under warranty)
    2 people like this.
  4. kawal

    kawal

    Messages:
    5
    Same problem, I was facing. These TASS guys are useless. Try flushing out the entire cooling system with nitrogen cleaning. Change the condensor if your car is 3 years old. Actually the magnetic clutch stops due to overheating of ac clutch. And this is due to some blockage in the system. I was made fooled by changing compressor - this is what company guys will tell you
    but finally you need to change condensor. - I m going to change it today. Hopefully everything shd be fine then.
  5. Maxtor

    Maxtor Amatore

    Messages:
    104
    New Delhi
    I am facing a similar problem, been facing it for quite some time. In fact it's been there since almost the beginning.

    Happens when it's very very hot outside. What exactly happens is car gives a strong jerk and AC trips(simultaneous) and then AC resumes again as though it's just been switched on(slowly).

    To be honest I am fed up with Fiat service at various workshops so I AM LIVING WITH IT. I have shown it again and again and there is a limit to patience - because they always say it is fixed whereas it is not. It is difficult to suddenly replicate what happens unless I go an a drive each time with these chaps just to show them. If it's happened to your car and mine it must be happening in many Fiats. So these guys should have a solution for it by now. I will take it up on my next time at the workshop.
  6. ramu_dodda

    ramu_dodda Amatore

    Messages:
    102
    hyderabad
    I have my LIENA having similar problem, AC works intermittently and it works in the morning when I park the vehicle overnight. but it doesn't work day time. when I start the CAR in the morning it works perfectly fine but when I drive to office and park , or stop the car on way and start the car again and AC never turn on. this is top end model emotion pack and has the solar sensor on the dashboard. we have changed the control panel ( climate control) and blower resistor but still no luck. need your advice here.
  7. ramu_dodda

    ramu_dodda Amatore

    Messages:
    102
    hyderabad
    pressure switch(comes with AC hose pipe) and blower motor has been replaced today, tested AC couple of times by switching on and off , so far no issues and should see for next 3 days and confirm.
  8. Cogweelz

    Cogweelz

    Messages:
    8
    Bangalored
    I have the exactly same problem with my MJD 2009 Emo Pk.

    Early mornings and nights the a/c cools me to freeze. But in day time once few minutes of riding the a/c gives off. In fact i can hear the compressor whistling sort of sound. But as sson I accelerate the a/c kicks and coos us. After few minutes, agin the circus happens. So I read @viveksonkhla solution and would give it a check this week. Prior to 6 months I had:

    1. replaced the condenser as a leakage was found.

    2. flushed and replaced the a/c gas

    3. The O rings replaced (twice, second was a week back when I felt the cooling was lower 'again').

    Hopefully i don't need to $hell out More

Share This Page