1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

FIAT LINEA BLUE AND ME NOT WORKING

Discussion in 'Linea' started by csr1969, May 13, 2015.

  1. csr1969

    csr1969 Amatore

    Messages:
    163
    KA 38, bidar, AP 10 secunderabad
    hyderabad
    Linea 1.3
    Hi guys,
    my linea's blue and me is not working since a week. Recently on 9th May 2015, I went for a general check-up for my linea as there was free summer camp going on. I said the same to the technician that blue and me is not working. After a thorough check up he said that we'll have to replace the whole blue and me module. The cost involved in it is Rs 13000/-.My question is that does a blue and me module cost so much? Has anyone faced this problem? If yes what is the solution.Guys please help me out, as it is very difficult for me to live without blue and me.
  2. prabhjot

    prabhjot Esperto

    Messages:
    2,446
    delhi ncr
    Hi @csr1969

    The two things you can try before you go in for the replacement:

    (a) disconnect and reconnect after a while the battery terminals, for a sort of 're-boot' of blue&me
    (b) have it opened up and try cleaning the electrical/electronic contacts within the blue and me module in the glovebox. This will require specialist electronic contact cleaning fluid, commonly available. You could get the fluid and have FASS attempt this for you if they're willing?

    These 2 techniques have often worked for those who've had the blue&me blues, esp (a) which is no big deal. btw, are you certain your battery is not 'over the hill'?

    Do look up the blue&me thread here on TFi, go through it, and PM those who've faced this issue of blue&me packing up. You'll get more specific advice from them.

    Thing is that FASS, like most dealers of any brand, are often too eager to 'change the part', in their case even under warranty.
  3. csr1969

    csr1969 Amatore

    Messages:
    163
    KA 38, bidar, AP 10 secunderabad
    hyderabad
    Linea 1.3
    Hi@prabhjot
    First of all thanks for your advice. Secondly my battery is not 'over the hill'and my car is out of warranty as it is a 2009 november model.
    Thanks for your advice and i'll certainly do as you said.:)
    prabhjot likes this.
  4. csr1969

    csr1969 Amatore

    Messages:
    163
    KA 38, bidar, AP 10 secunderabad
    hyderabad
    Linea 1.3
    Hi guys, I am planning for an aftermarket HU. My question is that should I go for an aftermarket HU or get the blue&me module replaced?
  5. manjunathkl

    manjunathkl Amatore

    Messages:
    61
    Bangalore
    Linea 1.4
    If you go for after market HU, you will lose the steering mounted controls for audio. It is not advisable to lose that. It is better to retain B&M. B&M has hardware and software.
    If it is the software issue, software can be re-installed using a thumbdrive. Go to B&M site download the relevant version and update it. It must start working.
    If it is is a hardware issue, you need to replace the part. That will be hurt the pocket for sure.

Share This Page