1. Introducing the smashing new Team FIAT T-Shirt !! To order yours click here : Team FIAT T-Shirt

Few concerns (minor electrical and body) - Punto Evo

Discussion in 'Exteriors / Body' started by santoshmandali, Jan 26, 2015.

  1. asimpleson

    asimpleson Esperto

    Messages:
    3,000
    Heptanesia
    Linea 1.3
    @jumu google the issue. There actually is a device to counter this static, something you carry or strap like thing. I am not sure Fiat will acknowledge the issue but you could still email them.
  2. jumu

    jumu Superiore

    Messages:
    969
    Chennai
    strap it on me??

    Abdul
  3. santoshmandali

    santoshmandali Amatore

    Messages:
    52
    Bengaluru, Vijayawada
    Punto Evo 1.3
    I got my vehicle checked today
    • For the place where the paint loss happened at the intersection point of chrome door handle and body of the car, they clicked the pics and sent to FIAT for replacing them. I am being told that they will replace it with newer ones.
    • They replaced one of the horn since it was not working
    • Plastic mold covering at the lock would also be replaced since they ordered for the specific part
    • Replaced RPS since that was making oozing sound when reverse gear is engaged
    • They also checked if there is any problem with electrical using a machine
    Unfortunately the following did not come up during the test they were doing / during test drive but still persist:
    • Media player going back to AUX from USB when I honk - experience this again in the evening
    • When the charger is in the 12V plug and reverse gear is engaged the RPS gives the distance as 0 and starts beeping even if there is no obstruction
    prabhjot likes this.
  4. prabhjot

    prabhjot Esperto

    Messages:
    2,453
    delhi ncr
    @santoshmandali I think you should've insisted on a replacement USB+AUX port (the one with the 'microsoft' print on its cover), rather than waiting for a reproduction of the issue for their witnessing. They really ought to be taking your word for it, you know, since this is evidently a common niggle. But a mere niggle it is, thankfully. Next time?

    This Reverse Parking Sensor accessory insert as cause of some electrical irritation is an instance of a superstition I have, something I learnt from my Dad years ago: never alter the stock electrical/electronic/mechanical condition of a car/bike you buy, even if an 'expert' does the installation.

    Hats off, then, to those who radically mod/amp/remap their cars: they're braver than I am!

    cheers, man
  5. Rahul Singh

    Rahul Singh Amatore

    Messages:
    133
    Bangalore
    Avventura 1.3 90 HP
    @Sapam: Your issue is an earthing issue, happened with me as well. I too would add couple of electrical/mechanical niggles that i am currently facing:
    1- Sometimes when reverse is disengaged, the display monitor doesn't go blank instead it switches to media mode. I have to manually switch it off.
    2- There is a faint sound from speakers when the car is switched on and then goes off in couple of seconds. Guess this might be normal behavior but with all the earthing problems i am still listing it out as an issue.
    3- Happened twice in span of my ownership till now, the reverse gear got stuck while reversing. Have to get this checked as soon as i get time.

    May be @prabhjot can throw some light on issue #3.
  6. Sapam

    Sapam Amatore

    Messages:
    92
    Bangalore
    Bangalore
    Punto Evo 1.3 90 HP
    Today the Media Player to AUX switch didn't happened so far. Even when honking. Yesterday it did switch once only. will monitor it for someday and see if it stop misbehaving. Today I opened the bonnet and wiped the area around the battery and other metals. I remember the washing guys at the Service Center liberally spraying the plastic polish liquid in the engine compartment. Just wondering if that could be the cause until it dries off completely.
    prabhjot likes this.
  7. Sapam

    Sapam Amatore

    Messages:
    92
    Bangalore
    Bangalore
    Punto Evo 1.3 90 HP
    One thing I noticed since two weeks is, the to AUX switching when honking is more frequent after a wash. Anyways i'll bring this issue with FASS and see what solution they have.
  8. asimpleson

    asimpleson Esperto

    Messages:
    3,000
    Heptanesia
    Linea 1.3
    Probability of some wiring issues and rare though but also a HU issue.
  9. jadesh

    jadesh Timido

    Messages:
    8
    Bengaluru
    Bengaluru
    Punto Evo 1.3
    I Bought EVO in Dec-14 (Oct-14 Mfd) I am facing static current issue near door side. I updated this issue to FIAT Service guys, as usual they refixed the grounding cable, i still feel the same issue. Fortunately even service fellow felt the shock (He was honest to admit this issue :). Do you know if this problem how is this rectified?.
    I never faced this issue in any of other cars.
  10. asimpleson

    asimpleson Esperto

    Messages:
    3,000
    Heptanesia
    Linea 1.3
    That works too :) but do google the issue. Static is an issue in cold regions. Lets hope its not a wiring thing though.

Share This Page